ESPlorer

windalser

New member
у меня автоматически не исполняется "Aurorun file after save to ESP", птичка в настройках установлена. (мелочь, конечно...)
 

Victor

Administrator
Команда форума
у меня автоматически не исполняется "Aurorun file after save to ESP", птичка в настройках установлена. (мелочь, конечно...)
Похоже, что эта проблема появилась с появлением TurboMode.
Попробуйте в обычном режиме будет ли запускаться?
 

windalser

New member
да, в нетурбо режиме авто-исполнение работает (попробовал на простейшем скрипте).
И еще - в нетурбо режиме интерпретатор ругается на комментарии типа
--[[
...
]]--

Скрипт:
bbb = 14 -- комментарий на кириллице

--[[
ccc = 1
]]--

eee = 13
 

Victor

Administrator
Команда форума
Кириллица корректно загружается только в TurboMode (в кириллице каждый символ двухбайтовый, когда NodeMCU отдает эхо команды, то умудряется между этими двумя байтами вставить свое приглашение "> ", я его вырезаю, но вместо кириллицы получается просто два байта, блин долго объяснять, короче только в TurboMode и, может быть, в DumbMode, будет работать)
 

boka17

New member
Вопросик от "осваивающего" ESPlorer, сорри, если я ещё просто не разобрался.
При выходе, хотелось-бы сохранять список открытых файлов в закладках scripts и открывать их при следующем запуске. После запуска программа сейчас всегда "пустая".
Как запустить файл, который уже есть во флэш ESP ? (программу ESPlorer только запустили - все пусто)
Надо нажать кнопку File list ... получим список файлов на экране, и ,далее , надо вручную набрать dofile('xxxx.lua')
я согласен, что командная строка -наше все :) и настоящий айтишник пишет команды со скоростью пулемета,
однако, годы работы с тоталкомандером сделали свое дело, и хочется просто дважды кликнуть по имени файла для запуска :)
Кнопка DoFile запускает файл только по имени активной закладки? т.е. надо сначала открыть файл на диске... а если их несколько надо открыть, вспомнить? (см предыдущее предложение о сохранении списка)
Было-бы здорово рядом с этой кнопкой DoFile сделать простой списк файлов, полученных по List - и запускать кликом по нему.

Ещё, про баги (?) Кнопка Save to ESP иногда работает как Send to ESP - хочу записать в память активную закладку со скриптом, жму Save ... по идее должен начаться скрипт записи (красные W в начале каждой строки) а происходит передача на выполнение каждой строки, с получением непонятных ошибок .....
В итоге имеем по List файл с нулевым размером.... После нескольких попыток (или какой-то магической последовательности действий- ещё не понял) все получается, и только что "плохой" файл записывается нормально.
У меня W7 32 яву обновил до последней.
 

boka17

New member
что-то тихо в форуме :(
Обнаружил неприятности с программой ESP8266Flasher.exe. Она не шьет мои платки ESP8266-01 на ноутбуке (HP Win7 32) Переходник USB-TTL. При этом на стационарном компе - тоже Win7 32, это-же железо и тот-же переходник распознало плату ESP и прекрасно все прошилось! В стационарном подключал во фронтальные USB.
На ноутбуке любые танцы с бубном не помогали - менял порты USB (перебрал все), менял номер порта в системе.....бесполезно - ESP8266Flasher.exe запускается, все настраиваю, жму Flash - моргает светодиод на переходнике USB-TTL и синхронно синий на плате модуля но прошивка не начинается! Разумеется, ресет с GPIO0=0. При этом терминалки (любые) прекрасно работают с этим портом - тот-же ESPlorer и другие, все четко, и на 9600 для nodemcu и на 115200 для AT команд.
Может, драйвера надо подбирать другие для USB-TTL... не знаю, но остальные программы с этим портом работают нормально.... а-н,нет- соврал! утилита XTCOM_UTIL тоже не заработала!
В общем, ноут HP не дружит с ESP софтом :(, а стационарник , материнка GIGABYTE, все прекрасно управляется и шьется.
 

boka17

New member
ок.
ESPlorer - кнопка "сохранить" (дискетка) записывает измененный скрипт на диск компа, заливает в память ESP..... мне кажется, это излишне. Допустим, я редактирую скрипт, он ещё не готов, надо просто сохранить работу.... а он заливается во флэш.
Логика кнопки "Сохранить" - это только записать текста скрипта на диск, загрузить - это только загрузить во флэш , ну и запуск - отдельная кнопка.
 

Victor

Administrator
Команда форума
ок.
ESPlorer - кнопка "сохранить" (дискетка) записывает измененный скрипт на диск компа, заливает в память ESP..... мне кажется, это излишне. Допустим, я редактирую скрипт, он ещё не готов, надо просто сохранить работу.... а он заливается во флэш.
Логика кнопки "Сохранить" - это только записать текста скрипта на диск, загрузить - это только загрузить во флэш , ну и запуск - отдельная кнопка.
На вкладке Settings уберите галочку "AutoSave file to ESP after save to disk"
 

Игорь

New member
1. Win8.1, ESPlorer206, FTDI. Open file, Save to ESP...
и в ответ сразу же:
stdin 1: unexpected symbol near '?'file.close();
и действительно первый символ первой строки (правое окно) - '?' Но в файле и в левом окне его нет...
стабильно и многократно, пока ВСЕ не выкл и вкл. При повторном вкл - может быть все ок
Что может быть?
2. Программа чуть более 4К.
Save - то с ошибками и ресетом, то (правда ОООчень редко) делает файл, но при его запуске - ресет
Send - может (но тоже не всегда) успешно прогрузить все до конца и программа работает
Итого - программа работает, но загрузить файл на выполнение нельзя. Бывало такое?
 

Victor

Administrator
Команда форума
1. Win8.1, ESPlorer206, FTDI. Open file, Save to ESP...
и в ответ сразу же:
stdin 1: unexpected symbol near '?'file.close();
и действительно первый символ первой строки (правое окно) - '?' Но в файле и в левом окне его нет...
стабильно и многократно, пока ВСЕ не выкл и вкл. При повторном вкл - может быть все ок
Что может быть?
2. Программа чуть более 4К.
Save - то с ошибками и ресетом, то (правда ОООчень редко) делает файл, но при его запуске - ресет
Send - может (но тоже не всегда) успешно прогрузить все до конца и программа работает
Итого - программа работает, но загрузить файл на выполнение нельзя. Бывало такое?
1. Попробуйте на вкладке Settings убрать галочку TurboMode
2. Бывают в NodeMCU дефекты файловой системы, которые лечатся либо форматированием, либо перепрошивкой
 

Игорь

New member
TurboMode улучшило загрузку, но основной глюк остался.
Перепрошил. Все то же самое - "с руки" все работает. Запуск файла - reset!
Файл ТУДА и ОТТУДА одинаковые (разница только в отсутствии CR (только LF) в файле ОТТУДА)
LuaUploader - все то же.
Надо вероятно признать, что файлы более 4К могут иметь проблемы!!! Мнение сугубо личное.
 

Victor

Administrator
Команда форума
TurboMode улучшило загрузку, но основной глюк остался.
Перепрошил. Все то же самое - "с руки" все работает. Запуск файла - reset!
Файл ТУДА и ОТТУДА одинаковые (разница только в отсутствии CR (только LF) в файле ОТТУДА)
LuaUploader - все то же.
Надо вероятно признать, что файлы более 4К могут иметь проблемы!!! Мнение сугубо личное.
я ESPlorer тестировал на файле размером 3400 байт (он в дистрибутиве в папке _lua) - проблем не возникало.
CR+LF вроде обязательно, а то интерпретатор может пытается все как одну большую строку обработать
Попробуйте увеличить размер моего тестового файла (простым копирование блоков в любом Win текстовом редакторе) и попробуйте
 

Игорь

New member
Тем не менее из модуля файл приходит без CR
Абсолютно точно. Длины файлов отличаются ровно на количество строк.
Да и в Notepad++ все видно...
200 строк и у меня RESET!
 

boka17

New member
Тем не менее из модуля файл приходит без CR
Абсолютно точно.
200 строк и у меня RESET!
Меня тоже "мучила" похожая ситуация - не проходила выгрузка в чип совершенно простых файлов.....
Мне кажется - 200 строк, это очень много для этого чипа, посмотрите на него :) он же маленький.
Пропуская "лирику" моих поисков, могу дать совет (разумеется, последнее слово за автором)
- залить в чип последнюю! версию прошивки - на стоковой вообще "швах"
- поставить движки миллисекунд на максимум(закладка Settings) - будет медленно, но загрузится. Потом можно уменьшать миллисекунды, пока не "засбоит" загрузка
у меня стабильнее работает в dumb mode и 300 ms
- не заливать много файлов и большого размера сразу, применить форматирование в начале.
Я грузил из примеров одновременно ds18b20-example.lua ds18b20-web.lua ds18b20.lua это 3406 +764+ 340 байт и ещё init.lua 469 байт - все работает, но попытка загрузить ещё файл - уже проблемы в виде циклического рестарта чипа.
 

Past

New member
Добрый день! что Вы решили по поводу общения с esp/nodemcu через telnet?
2 дополнительных ноги никому бы не помешали!
 

Past

New member
Добрый день еще раз :)
Добавьте возможность указать произвольное имя tty, чтобы можно было "приземлить" телнет в пайп через socat и указать пайп в качестве UART.
 

Victor

Administrator
Команда форума
Добрый день еще раз :)
Добавьте возможность указать произвольное имя tty, чтобы можно было "приземлить" телнет в пайп через socat и указать пайп в качестве UART.
ок.
А вот с телнетом как-то пока не ладится
 
Сверху Снизу