Realtek RTL872x (WiFi+BLE5.0)

pvvx

Активный участник сообщества
мне нужна нормальная отладка, а не заливатор. + проект оригинальный компилится вечность с оригинальными make файлами
Дык одним яром и не вечность, а:
KM0
1612190665031.png
KM4
1612190688651.png

33 секунды одним ядром Ryzen 1700 в WSL1, сам проект в Windows 10 x64 на HDD(!) RAM 64 GB.
В WSL1 и его tmpfs будет в 2-3 раза быстрее...
А если подредактировать скрипты - наверно и 5 секунд хватит с заливкой в Flash.
 

VasiliSk

New member
Вы целиком проект собрали или только последние стадии?
photo_2020-09-22_21-51-44.jpg
16 потоков полной сборки. не помню уже после того как я переписал половину мейков или до
 

pvvx

Активный участник сообщества
Вы целиком проект собрали или только последние стадии?
Посмотреть вложение 10526
16 потоков полной сборки. не помню уже после того как я переписал половину мейков или до
Полностью собрал, приямо счас для вас на старом компе (там оно сидит уже) - для скриншота.
Но факт что работает только одно ядро, т.е. один поток.
Первый проход естественно дольше - пока установит gcc и прочее...
 

pvvx

Активный участник сообщества
Вот такие cmd
km0_make.cmd:
Код:
wsl time make -s -C project/realtek_amebaD_va0_example/GCC-RELEASE/project_lp
pause
km4_make.cmd:
Код:
wsl time make -s -C project/realtek_amebaD_va0_example/GCC-RELEASE/project_hp CONFIG_WIFI_COUNTRY=RTW_COUNTRY_US CONFIG_WIFI_CHANNEL_PLAN=0x25
pause
Сам SDK исправлен (избавлен от console в SPI) и в трансляцию включено USB.
 

pvvx

Активный участник сообщества
В WSL2 значительно дольше. Из-за трансляции файловой системы винды в VM Ubuntu.
 

pvvx

Активный участник сообщества
проект оригинальный компилится вечность с оригинальными make файлами
Слепите создание бинарников по аналогии с
elf->bin всего-то пару строк на Питоне :)
Мне пока не до этого...
 

VasiliSk

New member
не пользовался раньше wsl, тулчейн добавил но на скобочку ругается
 

alutov

New member
Добрый день! Скачал и установил seeed-ambd-sdk, скомпилировал и прошил модуль BW16. Не могу поднять wifi. На AT+CWLAP, AT+CWMODE никакой реакции. Команды BLE, к примеру ATBS работают. Пытался писать свою программу, висит на функции wifi_on(), точнее rltk_wlan_init в ней. Ну то ладно. Ну а их пример должен же работать, если скомпилировался. Или где-то еще нужно править?
 
Сверху Снизу