Нужна помощь warning: espcomm_sync failed error: espcomm_open failed

serggg

New member
Доброго времени суток. Прошу помощи так как своими силами решить не получается. Имеем плату esp12e devkit при попытки залить пример через arduino ide 1.6.5 выдает ошибку:
.warning: espcomm_sync failed
error: espcomm_open failed
Через ESPlorer все работает , скечи заливаютя .
Хочу наладить управление со смартфона через blynk.
Заранее спасибо.
 

sally555

New member
Проблема с USB-COMадаптером, или скорость обмена не совпадает. У меня бывает такое, я просто вынимаю адаптер из USB, потом снова втыкаю и все работает. Пины Rst и GPIO0 кстати вручную потягиваете при заливке скетча или у вас умный USB-COMадаптер с четырьмя линиями? У меня был простенький с 2я линиями RX и TX, но я его переделал на 4е линии, добавил RTS и DTR, которые повесил на пины Rst и GPIO0 соответственно, благо что внутри адаптера стоит чип с полным RS-232 интерфейсом.
 

serggg

New member
Проблема с USB-COMадаптером, или скорость обмена не совпадает. У меня бывает такое, я просто вынимаю адаптер из USB, потом снова втыкаю и все работает. Пины Rst и GPIO0 кстати вручную потягиваете при заливке скетча или у вас умный USB-COMадаптер с четырьмя линиями? У меня был простенький с 2я линиями RX и TX, но я его переделал на 4е линии, добавил RTS и DTR, которые повесил на пины Rst и GPIO0 соответственно, благо что внутри адаптера стоит чип с полным RS-232 интерфейсом.
Спасибо. Попробую.
 

serggg

New member
Все оказалось очень просто. Перед первой прошивкой зажать кнопку flash. Дальше все заливается без проблем.
 

KAPbI4

New member
Столкнулся с такой проблемой.
Железка: ESP8266 D1 mini
IDE: Arduino IDE

На маке прошивается без проблем.
А вот под linux (ubuntu) выдает:
Код:
warning: espcomm_sync failed

error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed
решение проблемы - закоротить ногу D3 (она же GPIO0) на землю.
 
Последнее редактирование:

AndrewTaranov

New member
Доброго времени суток. Прошу помощи так как своими силами решить не получается. Имеем плату esp12e devkit при попытки залить пример через arduino ide 1.6.5 выдает ошибку:
.warning: espcomm_sync failed
error: espcomm_open failed
Через ESPlorer все работает , скечи заливаютя .
Хочу наладить управление со смартфона через blynk.
Заранее спасибо.
Столкнулся с такой же проблемой вроде перепробовал все, что советовал. Ошибка, ошибка и т.д. залез в диспетчер устройств скорость порта стояла 9600. Принудительно поставил 11520, управление аппаратное. В IDE установил скорость порта так же 115200, все пошло, скетчи заливаются без проблем.1.jpg 2.jpg
 
это GPIO0 на землю
Вообще-то в нормальных устройствах стоит либо тумблер либо спец схема на двух транзисторах и двух резисторах
Но если кнопка то ее надо держать пока ESP определит что надо писать во флеш
Спасибо так и было зажал на землю все заработало
 

Farhad

New member
Добрый день господа! Купил себе ESP8266MOD-12, букву после 12 не знаю где найти )) Вообщем пытаюсь прошить через АрдуиноУно, с помощью АрдуиноIDE, все соединил с подтягивающими резисторами, даже резет к GPIO16 через 470Ом зацепил. На линии RX и TX поставил два резисторных делителя, запустил, вижу в сети точку доступа AI-Thi..... т.е модуль запустился. Через Монитор порта АрдуиныИДЕ отправляю команды - тишина... Нашел что нужно одну линию от делителя освободить, освободил линию TX, т.к c RX это не прокатило )) Теперь RX с делителем, а TX на прямую. Получаю ответы на команды и дебаг при загрузке
ets Jan 8 2013,rst cause:2, boot mode:(1,6)
load 0x40100000, len 1856, room 16
tail 0
chksum 0x63
load 0x3ffe8000, len 776, room 8
tail 0
chksum 0x02
load 0x3ffe8310, len 552, room 8
tail 0
chksum 0x79
csum 0x79

2nd boot version : 1.5
SPI Speed : 40MHz
SPI Mode : DIO
SPI Flash Size & Map: 32Mbit(512KB+512KB)
jump to run user1 @ 1000

rf[112] : 03
rf[113] : 00
rf[114] : 01

SDK ver: 1.5.4(baaeaebb) compiled @ May 17 2016 19:23:54
phy ver: 972, pp ver: 10.1


AT+GMR

AT version:1.1.0.0(May 11 2016 18:09:56)
SDK version:1.5.4(baaeaebb)
Ai-Thinker Technology Co. Ltd.
Jun 13 2016 11:29:20
OK

Значит линия работает ок. Подтягиваю через резистор 10К GPIO0, рестартую модуль, WIFI точка пропадает, жму компилировать свою прошивку и она выдает ошибку
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed
Всяко пробовал, и резет держать на модуле, и GPIO0 дергать в разные моменты, нифига... ошибка одинакова. Настройки порта в диспетчере тоже сделал на 115200, тож самое... что я могу пропустить?
 

starol

New member
Значит линия работает ок. Подтягиваю через резистор 10К GPIO0, рестартую модуль, WIFI точка пропадает, жму компилировать свою прошивку и она выдает ошибку
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed
Всяко пробовал, и резет держать на модуле, и GPIO0 дергать в разные моменты, нифига... ошибка одинакова. Настройки порта в диспетчере тоже сделал на 115200, тож самое... что я могу пропустить?[/QUOTE]


добрый день!
как удалось Вам решить в итоге свою проблему? в аналогичной ситуации
 

Vit

New member
Словил на Wemos D1 R1 аналогичное. Тестером на GPIO0 видно было уровень единицы после сброса и примерно половину питания после попытки залить что-нибудь. Осциллографом увидел на GPIO0 частоту, а сигнал TX модуля был притянут ближе к питанию - не опускался ниже половины питания. Оказалось, что контакт разъёма (вилочка такая:)) TX при установке выгнули и оно в пластике аккуратненько:) попало в ячейку с GPIO16 и там замкнулось. Что за прошивка была, не знаю, но какую-то точку доступа оно поднимало. И, похоже, настраивало GPIO16 на выход с уровнем 1.
 
Сверху Снизу