Скрыть объявление
На нашем форуме недоступен просмотр изображений для неавторизованных пользователей. Если Вы уже зарегистрированы на нашем форуме, то можете войти. Если у Вас еще нет аккаунта, мы будем рады, если Вы к нам присоединитесь. Зарегистрироваться Вы можете здесь.

Wemos D1, esp8266 перестал определяться компом

Тема в разделе "Раздел для начинающих", создана пользователем technoartist, 22 май 2019.

  1. technoartist

    technoartist Новичок

    Сообщения:
    6
    Симпатии:
    0
    Начал изучение. Заливал скетчи, сталкивался с проблемами, не прошивалось, но все победил. Вчера залил, смотрел монитор порта. Выключил.
    Сегодня подключаю - иной раз синий светодиод мигнет, а чаще вообще тишина и темнота. В компе устройство не определяется.
    На другом компе то же самое, драйвера другие попробовал, кабелей несколько разных, в том числе тот что вчера работал.
     
  2. nikolz

    nikolz Гуру

    Сообщения:
    4.698
    Симпатии:
    452
    Сочувствую.
    какой вопрос?
     
  3. technoartist

    technoartist Новичок

    Сообщения:
    6
    Симпатии:
    0
    Какие существуют методы диагностики? Зачем на вемосе кнопка reset? С чего начинать поиск проблемы, учитывая вводные которые я описал?
     
  4. nikolz

    nikolz Гуру

    Сообщения:
    4.698
    Симпатии:
    452
    Для начала поставьте NODEMCU FIRMWARE PROGRAMMER
    с его помощью определите виден ли порт (втыкнуть кабель с вемос и вытыкнуть) порт появится в списке и пропадет
    потом попытаться залить этой прогой что угодно
    при этом определится мак адреса
    -------------
    если есть вольтметр то проверьте 3.3 вольта на внеш контакте или на 1117 на плате
    --------------
    остальное после этого
    об исполнении доложить.
     
  5. technoartist

    technoartist Новичок

    Сообщения:
    6
    Симпатии:
    0
    NODEMCU никак не видит устройство.
    на 3V3 вольтметр видит 3,23 вольта. на 5V видит 4,7 вольта
     
  6. nikolz

    nikolz Гуру

    Сообщения:
    4.698
    Симпатии:
    452
    источник питания какой?
    если это USB то должно быть 5 вольт или вольтметр проверяйте или источник слабый
    или потребление большое.
     
  7. technoartist

    technoartist Новичок

    Сообщения:
    6
    Симпатии:
    0
    и от компьютера, и от внешнего источника 3,23 и 4,5 соответственно. двумя разными мультиметрами
     
  8. nikolz

    nikolz Гуру

    Сообщения:
    4.698
    Симпатии:
    452
    нажимаете на кнопку RST диод мигает?
    на 5 вольт видит 4.7 это правильно
     
  9. nikolz

    nikolz Гуру

    Сообщения:
    4.698
    Симпатии:
    452
    поставьте программу терминала Tera Term
    проверьте появляется ли порт в списке портов при подключении кабеля с вемос.
    если есть то
    установите скорость 74880
    нажмите RST
    покажите картинку
     
  10. technoartist

    technoartist Новичок

    Сообщения:
    6
    Симпатии:
    0
    мигает в момент после того как отпускаю RST
     
  11. nikolz

    nikolz Гуру

    Сообщения:
    4.698
    Симпатии:
    452
    значит ESP исправна
    остается чип адаптера CH340 кабель и драйвер адаптера
     
  12. technoartist

    technoartist Новичок

    Сообщения:
    6
    Симпатии:
    0
    кабели менял. чип как проверить? визуально цел (полярность никак перепутать не мог). драйвер посоветуйте.
     
  13. CodeNameHawk

    CodeNameHawk Moderator Команда форума

    Сообщения:
    1.618
    Симпатии:
    180
    Вам уже написали
    https://esp8266.ru/forum/threads/esp-12f-ne-xochet-pereproshivatsja-kak-zastavit.2843/
     

Поделиться этой страницей