Wemos d1 mini на CH340 не видно в винде

Pashteton

New member
Подскажите. Есть пара Wemos d1 mini на CH340, подключаю к компу,
находит только неизвестное устройство с VIN_0000 и PIN_0000.
Пробовал по разному дрова ставить, на разных компах, виндах, и даже кабель 10см, везде результат одинаковый.
 

Shyster

New member
с VIN_0000 и PIN_0000. Обычно если умер USB девайс такое пишет. Это значит что устройство не возвращает данных, хотя система видит что что-то подключили.
 

Pashteton

New member
Это я понял. Но несколько устройств сразу не могли сдохнуть сразу.
Есть вариант, запитать ESP8266 от отдельного источника питания.
 

Shyster

New member
Это я понял. Но несколько устройств сразу не могли сдохнуть сразу.
Есть вариант, запитать ESP8266 от отдельного источника питания.
у почему. Был у меня случай когда в компе неправильно был подключен USB перевернут разъем. Что туда не включали все выгорало :)
Но в вашем случае, вы правы может бытьпроблемы с питанием. Может у вас где то коротит питание?
 

Shyster

New member
Вы лучше скажите, у когонибудь этот wemos d1 mini работает?
Я использую CH340 преходник и у меня с ним ни каких проблем небыло, т.е. связка CH340 - ESP8266 точно работает. А вот что там в wemos d1 min не знаю. Но скоре всего должно работать.

По фотто там ничего особенного нет. защитный диод, стабилизатор, CH340 + ESP. Еще транзисторы для чего то. Т.е. ничего такого нетчтоб не работало. Кстати проверьте питание на CH340
 

Shyster

New member

serrgee

New member
У меня Wemos D1 mini нормально подключается и работает.
USB\VID_1A86&PID_7523. Покупал у продавца, предлагавшего самую низкую цену.
 

Pashteton

New member
@serrgee На нем написано wemos ? Дайте ссылку, пожалуйста.
С отдельным питанием и подключением по ЮСБ фокус не вышел.
Попробовал подключиться через USB-UART адаптер, в терминале увидел какой то ответ и в конце ready )
Возможно битый ch340.

В оболочке ардуино столкнулся с проблемой длинных путей для ХР... поэтому залить ничего не смог.
 
Последнее редактирование:

planar74

New member
Olimex пошел путем FTDI? С ними тоже в свое время такая хрень происходила. Драйвера определяли неоригинальный чип и обнуляли PID/VID
 

Pashteton

New member
Очень похоже на то. Не догадался я второю плату со старым драйвером попробовать.
 

oleque

New member
У меня эти WeMoS D1 mini работали без проблем пару месяцев назад. Так что, теперь их нельзя подключать к компу, драйвер их поломает?
 

alfacom

New member
У меня эти WeMoS D1 mini работали без проблем пару месяцев назад. Так что, теперь их нельзя подключать к компу, драйвер их поломает?
У меня Вимос и сейчас работают без проблем. Вин 10, автообновление включено. Маловероятно, что драйвер их поломает.
 

telobezumnoe

New member
у меня было подобное на D1 в итоге я запустил его только зацепившись к аппаратному уарту, и через другой переходник юсб уарт. с продавца вернул пол цены.
 
Сверху Снизу