Загрузчик lua скриптов luadownloader

alexhi

New member
Написал под свою задачу загрузчик Lua скриптов. Общий смысл такой. Программа пишется в любом редакторе , а через загрузчик только заливается в модуль. Добавил еще часто используемые команды. Кому интересно попробуйте.
Вот внешний вид:

Все одним файлом,без "бантиков" Программа Beta.
 

Вложения

Последнее редактирование:

CHERTS

Moderator
Команда форума
На Win 7 x64 не работает программа, File List ничего не выводит, хотя файлы точно есть. А зугрузка тоже происходит странно, потом ничего не работает.
 

alexhi

New member
На Win 7 x64 не могу попробывать,нет. У меня Xp все работает,я еще дописал поля чтобы команды давать. А COM порт она находит к которому модуль подключен?Скорость 9600? Я писал на CBuilder6 и использовал компоненту TCOM для работы с COM портом. Может она глючит.По возможности проверю на 7.
 

alexhi

New member
Хм.. А если в нижней строке набираете например print("SASA") тоже ничего нет? У меня там задержка между отсылкой строк сделана 300мс просто delay,может она на 7/64 не так отрабатывается,или как писал выше компонента COM порта глючит. Как только найду PC с 7 попробую отпишу.
 

CHERTS

Moderator
Команда форума
А если в нижней строке набираете например print("SASA") тоже ничего нет?
Вообще пока не нажмешь Open File ни одна кнопка не активна, какой в этом смысл?

print(node.heap()) не отрабатывает, print("SASA") аналогично, собственно ESPlorer от Виктора тоже у меня не работает, возможно это беда x64 винды, но другой у меня нет и поэтому все грустно :(
 

alexhi

New member
И ESPLorer не пашет? Там вообще Java должно работать всюду по идее.Даже не знаю, а у вас переходник USB <--->TTL для модуля на чем? FTDI или CP может драйвер криво встал,хотя говорите что через терминал работает :( Может действительно беда с x64. По возможности проверю,самому интересно стало.
 

CHERTS

Moderator
Команда форума
И ESPLorer не пашет?
Не пашет, более того, написанный на питоне luatool так же не работает и его питоновский аналог nodemcu_file_util тоже в ступоре :(
Я уже прошил оригинальную nodemcu от разработчика, толку нуль, ни одна утилита не может залить lua скрипты :( блин, из консоли все отлично работает, хоть свою утилиту пиши.
 

alexhi

New member
Я бы все таки еще переходник USB TTL и драйвер его проверил, может например какие то игры с DTR DSR.
 

CHERTS

Moderator
Команда форума
C ESPLorer и питоновскими скриптами разобрались, оказывается ESPLorer при подключении ставил линию RTS в 0, а у меня она к RESET ESP подключена.

А вот Ваша программа не работает даже если я отключил RTS и DTR от платы ESP. Так что думаю дело в реализации работы с COM портом в Вашей прогремме.
 

alexhi

New member
Ну и отлично :) У меня там линии квитирования вообще не используются, наверное компонент TCOM все таки на Win7/64 не пашет. Он уже прилично старый,при случае поищу версию поновее и проверю
 

alexhi

New member
попробовал 2 версии 642 кб и 593.5 кб
Сейчас перезагрузил ,новую версию которой пользуюсь.У меня XP. Еще раз проверил.Все норм. А что у вас пишет? Открыли порт,загрузили скрипт и дальше Upload и ничего не происходит так? Переходник у меня на CP2102 только TXD и RXD
 

Igor

New member
LuaDownloader V1.0 в окне терминала ничего не выводится, при загрузки скрипта - он тоже не отображается нв окне
при нажатии на кнопочки .. происходит посылка команд на ESP8266 (мигает светодиод на USB-UART переходнике
на самой платке ESP8266 мигает синий светодид (т.е ESP8266 принимает и отвечает на команды, но в окне опять ничего не отображается).
Пришлось перейти наESP8266 LuaLoader 0.82
 

Igor

New member
Esp8266 подключена, сом порт настроен, скрипт загружен ...никакие кнопки не работают и на экран ничего не выводиться...
upload_2015-2-3_1-5-38.png
 
Сверху Снизу