Горит синим пламенем, то есть, светодиодом

Sever44

Member
Здоровья всем!
В режиме самоизоляции решил заняться старыми проектами и тут обнаружил, что мой
любимый ESP-201 горит синим светодиодом в рабочем режиме. В режиме загрузки не горит, вроде даже загружается (пишет "Загрузка завершена"). Но при выходе из режима светодиод загорается. Перепрошивка не помогла.
Что делать? Выбрасывать? Или можно вылечить?
Кто знает, подскажите.
Заранее спасибо.
 

CodeNameHawk

Moderator
Команда форума
Вы включились в соревнование на лучшую шутку?
Вы сами начали
вроде даже загружается
Она может или загрузиться или нет.

И да, но только для того, что бы вы поняли,что вопрос задан "слабо".
А насчет светодиода, то он никак не влияет на то работает ли есп или нет и даже не указывает работает она или нет.
Все зависит от программы.
В одной схеме он у меня горит, когда надо и все работает.
А насчет вопроса
Куда пишет "Загрузка завершена"? Прям на корпусе чтоли?
нет ничего странного, "обычно" после старта сама есп такого не пишет.
А что вы туда заливаете никто не знает.

В режиме загрузки не горит, вроде даже загружается (пишет "Загрузка завершена").
Возможно вы перепутали загрузку и прошивание или "загрузка прошивки", потому, что обычно загрузка это старт есп.
 
Последнее редактирование:

Dagoth Nik

New member
Всем привет. Напишу сюда, проблема похожая. Только я, помимо горящего светодиода, вижу ещё и ошибки в консоли, которые идут сплошным потоком, вызывая свечение этого самого светодиода.
В общем такая странная проблема (хотя может и не совсем проблема). У меня несколько модулей на ESP8266 и один из них начал себя вести крайне странно: удачно прошивается только через Arduino IDE. При прошивке через esptool.py (через терминал) или через NodeMCU Firmware Programmer (под виндами) готовыми бинарниками, после перезагрузки модуля, он (модуль) бесконечно сыпет в консоль ошибки и не загружает прошивку. Про готовые уточнил по той причине, что если бинарник создать в Arduino IDE и после этого залить через тот же esptool (и NodeMCU FP), то всё работает штатно.
Что ещё интересно, софт NodeMCU видит MAC-адрес точки доступа этого esp модуля начинающимся со 100 (я первый раз вообще MAC-адрес с трёхзначным числом вижу). Возможно это просто глюк прошивальщика, не знаю. У прочих модулей MAC'и выглядели вполне обычно.
И ещё кое-что. Esptool.py видит микросхему как ESP8285, со встроенной flash. Я пробовал выпаивать память и прошивать без неё и прошивка не идёт, выдаёт ошибку.
Снимок экрана 2020-05-10 в 02.08.17.png
Модуль - ESP-07, который с керамической антенной и разъёмом под внешнюю. Проблем нет ни с готовой платой NodeMCU, ни с другим модулем ESP-07, оба прошиваются нормально, через любой софт из тех, что пробовал.
Кто-нибудь с таким сталкивался?
И ещё вопрос: стандартная AT прошивка есть в виде INO скетча? Или только в виде bin файлов?
Заранее спасибо за помощь.
 
Сверху Снизу