Компиляция ESPWebDAV

Goldz

New member
Обращаюсь ко всем !!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Прошу помощи!!!!!!

Все скачал с ardyesp/ESPWebDAV

При компиляции дает ошибку ....... C:\Users\Gold\Documents\Arduino\libraries\SdFat\src/FatLib/FatFileSystem.h:95:13: error: 'class fs::File' has no member named 'open'

tmpFile.open(vwd(), path, oflag);



Несколько библиотек найдено для "SdFat.h"

Используется: C:\Users\Gold\Documents\Arduino\libraries\SdFat

Не используется: C:\Users\Gold\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.6.2\libraries\ESP8266SdFat

exit status 1

Ошибка компиляции для платы Generic ESP8266 Module.

Что я только не делал. Менял библиотеки и их расположение, менял IDE и версии плат ESP8266

Прошу поделиться информацией:

На какой версии IDE можно успешно программировать( у меня 1.8.1)

Какая версия менеджера плат подходит( у меня esp8266 by ESP8266 Community ver 2.6.2

Может быть есть еще какие то "подводные камни"

Помогите,мозг кипит, а дело стоит
 
Обращаюсь ко всем !!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Прошу помощи!!!!!!

Все скачал с ardyesp/ESPWebDAV

При компиляции дает ошибку ....... C:\Users\Gold\Documents\Arduino\libraries\SdFat\src/FatLib/FatFileSystem.h:95:13: error: 'class fs::File' has no member named 'open'

tmpFile.open(vwd(), path, oflag);



Несколько библиотек найдено для "SdFat.h"

Используется: C:\Users\Gold\Documents\Arduino\libraries\SdFat

Не используется: C:\Users\Gold\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.6.2\libraries\ESP8266SdFat

exit status 1

Ошибка компиляции для платы Generic ESP8266 Module.

Что я только не делал. Менял библиотеки и их расположение, менял IDE и версии плат ESP8266

Прошу поделиться информацией:

На какой версии IDE можно успешно программировать( у меня 1.8.1)

Какая версия менеджера плат подходит( у меня esp8266 by ESP8266 Community ver 2.6.2

Может быть есть еще какие то "подводные камни"

Помогите,мозг кипит, а дело стоит
 
Обращаюсь ко всем !!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Прошу помощи!!!!!!
Вы программируете систему жизнеобеспечения? :D

На какой версии IDE можно успешно программировать( у меня 1.8.1)
Какая версия менеджера плат подходит( у меня esp8266 by ESP8266 Community ver 2.6.2
Попробуйте последнюю версию IDE 1.8.10 или откатитесь на версию 2.5.2 ESP8266 Community
У меня тоже были подобные проблемы из-за нестыковки версий IDE и Board
 

CodeNameHawk

Moderator
Команда форума
А если и с этой версией платы не будет компилироваться, стоит написать автору на GitHub
 

Goldz

New member
Вы программируете систему жизнеобеспечения? :D


Попробуйте последнюю версию IDE 1.8.10 или откатитесь на версию 2.5.2 ESP8266 Community
У меня тоже были подобные проблемы из-за нестыковки версий IDE и Board
ПОМОГЛО
ДВА ДНЯ БИЛСЯ САМ
ВСЕМ СПАСИБО!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 
Сверху Снизу