Нужна помощь Модуль не работает после прошивки

Alkciviad

New member
Добрый день.
Прошу помочь понять, что я делаю не так

Поиск по форуму находил такую же проблему как у меня, но найти решение я не смог.
upload_2018-11-22_12-47-42.png
Изначально пользовался UDK и esptool мои прошивки на ESP-01 записывались иногда только с 3го раза, но работали даже если esptool выдавал ошибку например
upload_2018-11-22_12-46-21.png
Иногда после прошивки модуль начинал бешено отправлять что-то непонятное по uart, но это была редкость.
После того, как я обновил библиотеки SDK, даже после успешной записи модуль постоянно моргает LED и шлет что-то по UART.
Попробовал использовать esp8266 downloading tool не помогло, попробовал прошивать ранее не использовавшийся esp12E - та же картина. Попробовал использовать свежие blank.bin и init_data - не помогло.
upload_2018-11-22_12-54-19.png
 

nikolz

Well-known member
Добрый день.
Прошу помочь понять, что я делаю не так

Поиск по форуму находил такую же проблему как у меня, но найти решение я не смог.
Посмотреть вложение 6865
Изначально пользовался UDK и esptool мои прошивки на ESP-01 записывались иногда только с 3го раза, но работали даже если esptool выдавал ошибку например
Посмотреть вложение 6864
Иногда после прошивки модуль начинал бешено отправлять что-то непонятное по uart, но это была редкость.
После того, как я обновил библиотеки SDK, даже после успешной записи модуль постоянно моргает LED и шлет что-то по UART.
Попробовал использовать esp8266 downloading tool не помогло, попробовал прошивать ранее не использовавшийся esp12E - та же картина. Попробовал использовать свежие blank.bin и init_data - не помогло.
Посмотреть вложение 6866
попробуйте залить файл параметров wifi
его найдете в SDK в каталоге bin
 

Alkciviad

New member
Честно говоря плохо понял о каком именно файле вы говорите. Психанул и все переустановил, примеры типа "Hello_world" прошились офф download tool и заработали. Видимо проблема была в том, что я как-то неправильно поставил ESP8266_NONOS_SDK-3.0 вместо той, что шла в комплекте с UDK.
 

nikolz

Well-known member
Честно говоря плохо понял о каком именно файле вы говорите. Психанул и все переустановил, примеры типа "Hello_world" прошились офф download tool и заработали. Видимо проблема была в том, что я как-то неправильно поставил ESP8266_NONOS_SDK-3.0 вместо той, что шла в комплекте с UDK.
для UDK с последней SDK просто так не заработает
если хотите это сделать то можно перенести либы
 
Сверху Снизу