Не могу сдружить Arduino IDE и Linux Ubuntu 18.04 LTE для ESP32 - "Неверная библиотека найдена..."

Galiakberow

New member
Здравствуйте, уважаемые!
Никак не могу загрузить этот "гребаный" тестовый скетч в ESP32...
В WINDOWS 7 (64x) скетч загружался, но МК зацикливался в RESET е. Проблема отражена на последних страницах темы - https://esp8266.ru/forum/threads/oshibka-a-fatal-error-occurred-failed-to-connect-to-esp32-timed-out-waiting-for-packet-header.3472/page-4 . Остановились на том, что возможно проблема в драйвере порта (CH340).
Вот теперь перешел на Linux Ubuntu 18.04 LTE, в надежде на правильную работу порта, но снова проблема - не могу корректно установить, настроить библиотеки, платы для ESP32.
Делаю все по инструкции - espressif/arduino-esp32
В конечном счете выходит ошибка:
Неверная библиотека найдена в /home/user/arduino-1.8.5/hardware/espressif/esp32/libraries/BLE: /home/user/arduino-1.8.5/hardware/espressif/esp32/libraries/BLE
Неверная библиотека найдена в /home/user/arduino-1.8.5/hardware/espressif/esp32/libraries/AzureIoT: /home/user/arduino-1.8.5/hardware/espressif/esp32/libraries/AzureIoT
Traceback (most recent call last):
File "/home/user/arduino-1.8.5/hardware/espressif/esp32/tools/esptool.py", line 34, in <module>
import serial
ImportError: No module named serial
Несколько библиотек найдено для "WiFi.h"
Используется: /home/user/arduino-1.8.5/hardware/espressif/esp32/libraries/WiFi
Не используется: /home/user/arduino-1.8.5/libraries/WiFi
exit status 1
Ошибка компиляции для платы Noduino Quantum.
Неверная библиотека найдена в /home/user/arduino-1.8.5/hardware/espressif/esp32/libraries/BLE: /home/user/arduino-1.8.5/hardware/espressif/esp32/libraries/BLE
Неверная библиотека найдена в /home/user/arduino-1.8.5/hardware/espressif/esp32/libraries/AzureIoT: /home/user/arduino-1.8.5/hardware/espressif/esp32/libraries/AzureIoT
Неверная библиотека найдена в /home/user/arduino-1.8.5/hardware/espressif/esp32/libraries/BLE: /home/user/arduino-1.8.5/hardware/espressif/esp32/libraries/BLE
Неверная библиотека найдена в /home/user/arduino-1.8.5/hardware/espressif/esp32/libraries/AzureIoT: /home/user/arduino-1.8.5/hardware/espressif/esp32/libraries/AzureIoT
Подскажите, пожалуйста! Может кто сталкивался?
С уважением и надеждой на отзыв.

P.S. С этими PYTHON - ами, PIPSERIAL - ми их версиями (3.5, 2.7) совсем запутался))
 

Вложения

nikolz

Well-known member
Здравствуйте, уважаемые!
Никак не могу загрузить этот "гребаный" тестовый скетч в ESP32...
В WINDOWS 7 (64x) скетч загружался, но МК зацикливался в RESET е. Проблема отражена на последних страницах темы - https://esp8266.ru/forum/threads/oshibka-a-fatal-error-occurred-failed-to-connect-to-esp32-timed-out-waiting-for-packet-header.3472/page-4 . Остановились на том, что возможно проблема в драйвере порта (CH340).
Вот теперь перешел на Linux Ubuntu 18.04 LTE, в надежде на правильную работу порта, но снова проблема - не могу корректно установить, настроить библиотеки, платы для ESP32.
Делаю все по инструкции - espressif/arduino-esp32
В конечном счете выходит ошибка:

Подскажите, пожалуйста! Может кто сталкивался?
С уважением и надеждой на отзыв.

P.S. С этими PYTHON - ами, PIPSERIAL - ми их версиями (3.5, 2.7) совсем запутался))
Ну и напрасно перешли. Linux не для начинающих.
Доделайте там. вам же указывалось что у ESP32 должен быть режим флеш DIO а e вас SDIO Вы так и не исправили.
 

Galiakberow

New member
@nikolz, доделал. Действительно, нужно было в настройках выбрать FlashMode = DIO и еще FlashFreq =40Mhz. Для этого нужно выбрать плату с такими настройками, в некоторых платах библиотеки Arduino такие настройки отсутствуют. Я выбрал - ESP32 Dev Module.

Насчет работы в Linux, я бы хотел конечно переехать туда, т.к. мне показался он более шустрым. Так что тема более чем актуальна для меня, и прошу от Вас помощи!
 

Galiakberow

New member
Добрый день!
Посмотрите, пожалуйста, мои команды набранные в терминале - может сможете определить, что неправильно делаю:
user@KLAMAS:~$ history
1 pip help
2 sudo apt install python-pip
3 sudo apt-get install python3-pip
4 pip help
5 sudo apt-get install python3-pip
6 pip help
7 pip3 help
8 . install.sh
9 .install.sh
10 . install.sh
11 git clone espressif/arduino-esp32 esp32
12 cd esp32/tools/
13 python get.py
14 python3 get.py
15 sudo usermod -a -G dialout $user
16 sudo apt-get install git
17 cd /Applications/Arduino_*/Contents/java/hardware/
18 cd /Applications
19 . uninstall.sh
20 . install.sh
21 . uninstall.sh
22 . install.sh
23 . uninstall.sh
24 . install.sh
25 . uninstall.sh
26 . install.sh
27 ln -s /path/to/python3 /usr/bin/python
28 alias python3='python'
29 python help
30 python3 help
31 sudo apt install python
32 sudo apt install python3
33 python get.py
34 pip --version
35 pip3 --version
36 alias python3='python'
37 python help
38 python3 help
39 python get.py
40 python3 get.py
41 python pet.py
42 sudo apt install python
43 sudo python get-pip.py
44 sudo pip install pyserial
45 sudo pip3 install pyserial
46 sudo python3 get-pip.py
47 history
user@KLAMAS:~$ ^C
user@KLAMAS:~$
 

CodeNameHawk

Moderator
Команда форума
Попробовал установить на xubuntu.
Установил по инструкции с espressif/arduino-esp32
Код:
sudo usermod -a -G dialout $USER && \
sudo apt-get install git && \
wget https://bootstrap.pypa.io/get-pip.py && \
sudo python get-pip.py && \
sudo pip install pyserial && \
mkdir -p ~/Arduino/hardware/espressif && \
cd ~/Arduino/hardware/espressif && \
git clone https://github.com/espressif/arduino-esp32.git esp32 && \
cd esp32 && \
git submodule update --init --recursive && \
cd tools && \
python2 get.py
Выдало ошибку нет прав на некоторые папки.
Код:
The directory '/home/marian/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/marian/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Запустил дополнительно
Код:
sudo -H pip install pyserial
выдало :
Код:
Requirement already satisfied: pyserial in /usr/local/lib/python2.7/dist-packages (3.4)
При открытии Монитора порта выдавало ошибку, что нет прав на открытие прота (у меня это /dev/ttyS0)

Вылечилось при помощи Не активен последовательный порт Arduino IDE в linux | sadeb
Код:
sudo usermod -aG dialout marian
sudo chmod a+rw /dev/ttyS0
У вас для усб поменяется /dev/ttyS0
 
Сверху Снизу