Не удается подключиться к точке доступа ESP-01

koluna

New member
Всем привет!

AT+GMR

AT version:0.40.0.0(Aug 8 2015 14:45:58)
SDK version:1.3.0
Ai-Thinker Technology Co.,Ltd.
Build:1.3.0.2 Sep 11 2015 11:48:04
OK
AT+CWMODE?

+CWMODE:2

OK
AT+CWSAP?

+CWSAP:"ESP_10B5D2","",1,0,4

OK
Вижу точку доступа с ПК и со смартфона. Но подключиться к ней не могу.
Посоветуйте, пожалуйста, что делать.
Посоветуйте, пожалуйста, ПО для поиска и анализа Wi-Fi сетей.
 

koluna

New member
koluna, попробуйте пароль [inline]ai-thinker[/inline]
Не получается... возможно, я делаю что-то не так...
Windows 7 на нетбуке перестала сеть видеть...
Со смартфона сеть видна.

Умаялся...
К точке смог подключиться только после сброса к заводским установкам. При этом, кстати, поменялся SSID: ESP_10B5D2 -> AI-THINKER_10B5D2
Почему-то AT+CWSAP_CUR работает только с параметром шифрования 0.
AT+CWSAP_CUR="AAA","123",1,0,4


OK
AT+CWSAP_CUR="AAA","123",1,2,4


ERROR
AT+CWSAP_CUR="AAA","123",1,3,4


ERROR
AT+CWSAP_CUR="AAA","123",1,4,4


ERROR
 
Последнее редактирование:

koluna

New member
Может лог поможет? Попробую снять...
При старте модуля через GPIO2 лог выдается так же как и через основной порт (со сменой скорости)?
Вижу сначала мусор (будто скорость не совпадает), а потом на 115200 читабельные сообщения.

Это при старте модуля.
mode : softAP(5e:cf:7f:12:4b:64)
add if1
dhcp server start:(ip:192.168.4.1,mask:255.255.255.0,gw:192.168.4.1)
bcn 100
AT+CWSAP_CUR="AAA","1",1,0,1
del if1
usl
sul 0 0
add if1
dhcp server start:(ip:192.168.4.1,mask:255.255.255.0,gw:192.168.4.1)
bcn 100
На AT+CWSAP_CUR="AAA","1",1,4,1 ничего не выдает в лог, только ошибка (см. выше).
 
Сверху Снизу