Скрыть объявление
На нашем форуме недоступен просмотр изображений для неавторизованных пользователей. Если Вы уже зарегистрированы на нашем форуме, то можете войти. Если у Вас еще нет аккаунта, мы будем рады, если Вы к нам присоединитесь. Зарегистрироваться Вы можете здесь.

Eclipse plug-in для Sming

Тема в разделе "Sming Open Source Framework", создана пользователем sharky, 9 апр 2015.

  1. sharky

    sharky Читатель

    Сообщения:
    32
    Симпатии:
    12
    Спасибо. Очень хорошо, что под ждк8 завелось, т.к. тестил под 7ждк.
     
  2. sherr

    sherr Читатель

    Сообщения:
    36
    Симпатии:
    6
    Проблемки - при выборе порта приходится работать стрелкой вниз и Enter, мышью можно только открыть падающий список,
    заметная задержка при приёме первого ответа от платы (как будто заполняеся буфер), неравномерная скорость отображения
    регулярно приходящих ответов(пробовал в диапазоне 0,5-3 сек), вставляет пробелы в произвольные места в принимаемых сообщениях (примерно 1 на 30- 40 символов) .НО пользуюсь, удобно не выходя из Eclipse .
     
  3. sharky

    sharky Читатель

    Сообщения:
    32
    Симпатии:
    12
    @sherr Подробней опишите как именно не получается мышей порт выбрать.

    Завтра вечером буду посмотреть.
     
  4. sherr

    sherr Читатель

    Сообщения:
    36
    Симпатии:
    6
    Щелчком только можно открыть выпадающий список, всё остальное получается только стрелками и Enter.
     
  5. sharky

    sharky Читатель

    Сообщения:
    32
    Симпатии:
    12
    В терминале пофикшены лишние пробелы, настроен апдейт цикл плагина.
    Поменялся апдейт-сайт, см. топовую тему.
     
    JustACat нравится это.
  6. artp

    artp Новичок

    Сообщения:
    11
    Симпатии:
    0
    Получаем: This domain name expired on 2015-06-17 18:00:07


    Гм...???
     
  7. sharky

    sharky Читатель

    Сообщения:
    32
    Симпатии:
    12
    Эм. Продолбал продлить, ща поправлю, сорри.

    Вроде ожил уже, у меня по крайней мере показывает норм.
     
    Последнее редактирование: 30 июн 2015
  8. artp

    artp Новичок

    Сообщения:
    11
    Симпатии:
    0
    Ага, спасибо.
     
  9. Past

    Past Читатель

    Сообщения:
    60
    Симпатии:
    9
    Получаю ошибку
    ```
    Cannot complete the install because one or more required items could not be found.
    Software being installed: ECLE: Eclipse embedder tools 1.0.0.201505081442 (org.ploys.ecle.feature.feature.group 1.0.0.201505081442)
    Missing requirement: ECLE: Eclipse embedder tools 1.0.0.201505081442 (org.ploys.ecle.plugin 1.0.0.201505081442) requires 'package org.eclipse.cdt.managedbuilder.language.settings.providers 0.0.0' but it could not be found
    Cannot satisfy dependency:
    From: ECLE: Eclipse embedder tools 1.0.0.201505081442 (org.ploys.ecle.feature.feature.group 1.0.0.201505081442)
    To: org.ploys.ecle.plugin [1.0.0.201505081442]
    ```
    Eclipse Version: 3.8.1 на убунте
     
  10. sharky

    sharky Читатель

    Сообщения:
    32
    Симпатии:
    12
    Судя по ошибке или не установлен плагин для разработки на C/C++ или комплект эклипсовый версии 3.8 и 4.4.2 на которой плагин писался отличаются по апи и пакетам и плагины под новый не подходят под старый, попробуй доставить CDT (C Development Toolkit) или обновить эклипс.
     
  11. tac_evaworcim

    tac_evaworcim Новичок

    Сообщения:
    1
    Симпатии:
    0
    сайт опять умер? eclipse выдаёт:
    Код (Text):
    1. No repository found at http://eclipse.ploys.org/
     
  12. sharky

    sharky Читатель

    Сообщения:
    32
    Симпатии:
    12
    Угу, грабли с винтами на сервере, постараюсь на днях разобраться
     
  13. sharky

    sharky Читатель

    Сообщения:
    32
    Симпатии:
    12
    Всем привет!

    Сервер починили, http://ecle.ploys.org/
    Лето/осень были насыщенными, не было времени особо позаниматься плагином и еспхами,
    надеюсь снова включиться в работу со следующей недели
     

Поделиться этой страницей