Eclipse plug-in для Sming

sharky

New member
Можно, я отпишусь. Eclipse Luna, JRE 1.8.025 кажется, Debian 32byte. Поставилось без проблем, терминал пробовал пока только на приём -
работает, но изредка подтормаживает и добавляет пробелы . Хорошее начало, так держать !
Спасибо. Очень хорошо, что под ждк8 завелось, т.к. тестил под 7ждк.
 

sherr

New member
Проблемки - при выборе порта приходится работать стрелкой вниз и Enter, мышью можно только открыть падающий список,
заметная задержка при приёме первого ответа от платы (как будто заполняеся буфер), неравномерная скорость отображения
регулярно приходящих ответов(пробовал в диапазоне 0,5-3 сек), вставляет пробелы в произвольные места в принимаемых сообщениях (примерно 1 на 30- 40 символов) .НО пользуюсь, удобно не выходя из Eclipse .
 

sharky

New member
@sherr Подробней опишите как именно не получается мышей порт выбрать.

Завтра вечером буду посмотреть.
 

sherr

New member
Щелчком только можно открыть выпадающий список, всё остальное получается только стрелками и Enter.
 

sharky

New member
В терминале пофикшены лишние пробелы, настроен апдейт цикл плагина.
Поменялся апдейт-сайт, см. топовую тему.
 

sharky

New member
Эм. Продолбал продлить, ща поправлю, сорри.

Вроде ожил уже, у меня по крайней мере показывает норм.
 
Последнее редактирование:

Past

New member
Получаю ошибку
```
Cannot complete the install because one or more required items could not be found.
Software being installed: ECLE: Eclipse embedder tools 1.0.0.201505081442 (org.ploys.ecle.feature.feature.group 1.0.0.201505081442)
Missing requirement: ECLE: Eclipse embedder tools 1.0.0.201505081442 (org.ploys.ecle.plugin 1.0.0.201505081442) requires 'package org.eclipse.cdt.managedbuilder.language.settings.providers 0.0.0' but it could not be found
Cannot satisfy dependency:
From: ECLE: Eclipse embedder tools 1.0.0.201505081442 (org.ploys.ecle.feature.feature.group 1.0.0.201505081442)
To: org.ploys.ecle.plugin [1.0.0.201505081442]
```
Eclipse Version: 3.8.1 на убунте
 

sharky

New member
Получаю ошибку
```
Cannot complete the install because one or more required items could not be found.
Software being installed: ECLE: Eclipse embedder tools 1.0.0.201505081442 (org.ploys.ecle.feature.feature.group 1.0.0.201505081442)
Missing requirement: ECLE: Eclipse embedder tools 1.0.0.201505081442 (org.ploys.ecle.plugin 1.0.0.201505081442) requires 'package org.eclipse.cdt.managedbuilder.language.settings.providers 0.0.0' but it could not be found
Cannot satisfy dependency:
From: ECLE: Eclipse embedder tools 1.0.0.201505081442 (org.ploys.ecle.feature.feature.group 1.0.0.201505081442)
To: org.ploys.ecle.plugin [1.0.0.201505081442]
```
Eclipse Version: 3.8.1 на убунте
Судя по ошибке или не установлен плагин для разработки на C/C++ или комплект эклипсовый версии 3.8 и 4.4.2 на которой плагин писался отличаются по апи и пакетам и плагины под новый не подходят под старый, попробуй доставить CDT (C Development Toolkit) или обновить эклипс.
 

sharky

New member
Всем привет!

Сервер починили, http://ecle.ploys.org/
Лето/осень были насыщенными, не было времени особо позаниматься плагином и еспхами,
надеюсь снова включиться в работу со следующей недели
 
Сверху Снизу