Нужна помощь esp witty cloud (ESP-12) - проверка работоспособности

CodeNameHawk

Moderator
Команда форума
вы извините, но тут глупость говорите.
К процессу загрузки это не имеет никакого отношения.
То есть вы утверждаете, что вне зависимости от состояния gpio0 во время включения питания, процесс загрузки никак не измениться?
А я то всегда считал, что если на gpio0 во время подачи питания будет низкий уровень, то есп перейдет в режим прошивки.

Любая программа может использовать gpio0 как хочет и выставлять там что угодно.
Противного я и не утверждал.
 

CodeNameHawk

Moderator
Команда форума
Что бы было понятно, что я хотел сказать.
"Какая то из прошивок могла привести к тому, что теперь на GPIO0 всегда малое напряжение, а это не дает возможности запуститься есп"
Читать так :
Во время очередного прошивания, есп сбрендила и сама устанавливает на GPIO0 низкий уровень.(а не прошивка, которую в есп заливают)
Причины такого поведения мне не известны, просто какой то сбой.
 

max506

New member
Вы зациклились, что раньше так работало, а сейчас нет.
С того времени многое изменилось, нп. усб провод надломился и стал меньше току пропускать, пыль на плату осела, флюс не смыт до конца и.т.д.

Для того, чтобы быть уверенным, что там ищешь, где надо, надо убрать или уменьшить влияние всех других факторов.
Значит нужен внешний блок питания с запасом ( 5В 2А и потом на стабилизатор 3,3В), все нужные резисторы и все замеры.
Если вы хотите сделать по своему - удачи.
Уважаемый CodeNameHawk,
Большое спасибо, что Вы помогаете.
Кожей чувствую, что плата моя живая, но реанимировать не получается.
Готов выполнять все Ваши рекомендации для достижения результата.
Заранее спасибо)

Да, модуль умер после заливки прошивки ARDUINO MEGA SERVER
 
Последнее редактирование:

Сергей_Ф

Moderator
Команда форума
вы утверждаете, что вне зависимости от состояния gpio0 во время включения питания, процесс загрузки никак не измениться?
я утверждаю, что независимо от того, что выставила программа во время работы, это никак не влияет на состояние пина gpio0 во время загрузки. Т.е. после включения питания или сброса esp.
Таким образом, замер напряжения на пине 0 имеет смысл только при удержании кнопки Reset. А иначе уже меряется результат работы программы, а не исходный уровень.
 

Сергей_Ф

Moderator
Команда форума
@max506 привозите свою плату мне, я вам бесплатно её поменяю. Работаю на Воробьевых горах. Пишите в личку - созвонимся.
 

max506

New member
Дорогой Сергей.
Надеюсь совместными усилиями и доходчивыми советами сообщество поможет мне оживить модуль. Либо признать его годным к утилизации)))
 

CodeNameHawk

Moderator
Команда форума
Готов выполнять все Ваши рекомендации для достижения результата.
Значит нужен внешний блок питания с запасом ( 5В 2А и потом на стабилизатор 3,3В), все нужные резисторы и все замеры.
Для начала померьте напряжение на каждом выводе есп. относительно минуса питания.
(две платы соединены вместе и подключены к компу)
 

max506

New member
Для начала померьте напряжение на каждом выводе есп. относительно минуса питания.
(две платы соединены вместе и подключены к компу)
Платы соединены вместе и подключены к ноутбуку в нижний разъем ESP Witty.
Напряжение между Vcc-Gnd 5.11
Далее замеры между Gnd и ногами колодки верхней платы:
REST 4.51
ADC 0.6
CH-PD 2.57
GPIO16 0
GPIO14 0
GPIO12 0
GPIO13 0
TX 5
RX 5.1
GPIO5 0
GPIO4 3.27
GPIO0 4.6
GPIO2 0.97
GPIO15 0
 

max506

New member
Как говорил доктор Хаус, все врут
Нет не врут :)
Просто раньше я мерил на выводах микрухи непосредственно.
А надписи GPIO смещены относительно этих выводов. Вот и получилось, что замерял на GPIO2.

A что показывают замеры? Жив мой модуль?
 

CodeNameHawk

Moderator
Команда форума
Запустите на компе терминал и посмотрите, что выдает при старте.
 

max506

New member

Вложения

CodeNameHawk

Moderator
Команда форума
и в том ли месте я замеряю.
Для начала разберитесь в каком вы месте мериете, все надо мерить на контактах самой есп, а не на гребенке, а есп ноги всегда в одном и том же месте.
Смотреть загрузку надо на скорости 76000.
 

max506

New member
Смотреть загрузку надо на скорости 76000.
Ввел вручную скорость 76000 (в списке предустановленных скоростей отсутствует).
В порт не выводится ничего.
Замеры напряжения непосредственно на выводах esp:
VCC-GND 3.3
REST-4.5 ADC-0,5 CH-PD-2.56 GPIO16-0 GPIO14-0 GPIO12-0 GPIO13-0
TXD-4.99 RXD-0 GPIO5-0 GPIO4-3.27 GPIO0-4.59 GPIO2-0 GPIO15-0
 
Последнее редактирование:

CodeNameHawk

Moderator
Команда форума
На GPIO2 должна быть лог единица.
Сделайте фото платы с двух сторон, что бы было видно что подключено к GPIO2
 

max506

New member

Вложения

Сверху Снизу