Нужна помощь Esp8266 питание

FlasheR

New member
Всем привет. Имеется esp8266 (01) + arduino UNO (в качестве переходника для rx/tx) и реле(все китайское). Не получается по человечески запитать esp(знаю, что нужно 3.3В и >300mA тока), подключал через питание ардуины 3.3в - работало, но нестабильно, постоянно рвалась связь. Грешил на питание и преобрел AMS1117 3.3v модуль,
он выдает 3.29В, но esp походу не хватает(блоки питания пробовал на 5В и 7В по 1А и 2А), попробовал без модуля подключит через Стабилизатор AMS1117
но тоже без успеха. Идеи кончаются, плюнул и запитал от 5В от ардуино, к моему удивлению завелась с пол оборота, все шустро, потерь нет, но есть одно НО после того как я залил lua код через ESPlorer все идеально работает до перезагрузки esp, после в нем уже нет моего кода и он соответственно не работает.

В чем моя ошибка?
 

dimnsk

New member
Проверяйте питание под нагрузкой.
И все соединения проверьте.
 

FlasheR

New member
Вообщем решил тем, что прошивается и заливается программа только при 5В , работать может от 3.3В
Залил NodeMcu, залил код который конектится к wifi и поднимает веб-сервер, в нем есть 2 кнопки вкл/выкл (делаю для реле)
все работает! подключается к вафле (D-link DSL-2640U), получает ip, захожу на него все ок, реле щелкает)) НО изменил ssid и пасс к wifi в коде(для того чтобы проверить на другом роутере) и теперь роутер (zyxel Keenetic 4G II) зависает когда выдаст ip .. я не понимаю почему ! может это все быть из-за роутера или может опция какая то стоит? Подскажите пожалуйста
 
Сверху Снизу