Модуль BW12

aloika

Active member
Чем шьёте и какой SDK используете?
Еще ничем не шью, плату потихоньку развожу только. Других дел всяких много, "суета сует и томление духа".
Собираюсь прошить свалку от pvvx-а для начала. SDK тоже им редактированная. Чем прошивать - через UART скриптом, который там же есть. SWD тоже развожу, вдруг что и J-Link'ом получится.
 

Alexander

Member
Openocd нормально коннектится через stlink-v2 китайский. Я его вроде в Jlink перешивал, но это было так давно, что кажется неправдой. Может это вообще был второй, который куда-то запропастился.
Bash:
sudo openocd -f /usr/share/openocd/scripts/interface/stlink-v2.cfg -f /usr/share/openocd/scripts/target/rtl8710.cfg
Open On-Chip Debugger 0.10.0
Licensed under GNU GPL v2
For bug reports, read
    http://openocd.org/doc/doxygen/bugs.html
Info : auto-selecting first available session transport "hla_swd". To override use 'transport select <transport>'.
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
adapter speed: 2000 kHz
adapter_nsrst_delay: 200
ameba1_init
Info : Unable to match requested speed 2000 kHz, using 1800 kHz
Info : Unable to match requested speed 2000 kHz, using 1800 kHz
Info : clock speed 1800 kHz
Info : STLINK v2 JTAG v28 API v2 SWIM v7 VID 0x0483 PID 0x3748
Info : using stlink api v2
Info : Target voltage: 3.219512
Info : rtl8195a.cpu: hardware has 6 breakpoints, 4 watchpoints
Info : accepting 'telnet' connection on tcp/4444
Код:
$ telnet localhost 4444
Trying ::1...
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Open On-Chip Debugger
> reset halt
timed out while waiting for target halted
TARGET: rtl8195a.cpu - Not halted
in procedure 'reset'
in procedure 'ocd_bouncer'
Не сразу нашёл где у модуля SWD. В документации на модуль информации нет.
SWCLK GPIO_A14 12(0)
SWDIO GPIO_A15 14(5)
В скобках после номеров контактов модуля даны номера модуля ESP-12F. Под них на Али продаются платы, а модули полностью совместимы по габаритам и BW12 без проблем паяются на платы для ESP-12F.

Со "свалкой" пока не разобрался. Я честно говоря как-то сразу и не нашёл и не знал, что есть для B.
 

Alexander

Member
Что-то после заливки через OTA boot_all.bin из RTL0B_WEB модуль окирпичился :(

---------------------
Погорячился. Отвечает.
 

Alexander

Member
И всё равно что-то не так.
Код:
# ATSO=192.168.50.21,1234
[ATSO] OK
Но при этом
Код:
DownloadServer.exe 1234 ota1.bin
c():checksum 0x1c05704
Listening on port (1234) to send ota1.bin (280660 bytes)

Waiting for client ...
Accept client connection from 192.168.50.80
Send checksum and file size first
Send checksum byte 12
Sending file...
..........................................................
А boot_all.bin грузится
Код:
DownloadServer.exe 1234 boot_all.bin
c():checksum 0x61825
Listening on port (1235) to send boot_all.bin (4120 bytes)

Waiting for client ...
Accept client connection from 192.168.50.80
Send checksum and file size first
Send checksum byte 12
Sending file...
.....
Total send 4120 bytes
 

Alexander

Member
Может кто поделится бинарником загрузчика, того, который можно загрузить по OTA из AT прошивки?
 

Alexander

Member
Чем прошивать - через UART скриптом, который там же есть.
Не шьётся у меня через UART.
Для старта модуля в режиме UART_DOWNLOAD требуется замкнуть RESET на GND и затем притянуть TX (GPIOA30) на GND, отпустить RESET и затем TX.
На данном модуле RESET - pin 3; GPIOA30 - pin 11.

Код:
$ python ./mkb/rtltool.py -p /dev/ttyUSB0 wf 0x00000 ./build/bin/boot_all.bin
Connecting...
Failed to connect device on /dev/ttyUSB0 !
 

Alexander

Member
То же самое. А какой UART использовать?
Я подключал к UART0.
Их там всего 2, второй занят сбросом - GPIOA30
 

Alexander

Member
С родной утилитой под Windjws та же проблема.
Код:
COM3 is open successfully!
Uart download server has started...
Только она не отваливается по таймауту, а ждёт чего-то.

С ESP было заметно проще.
 

pvvx

Активный участник сообщества
С ESP было заметно проще.
Используйте ESP - кто вас принудил брать что-то другое, немного более сложное для вас?
esptool откатывали 7 лет и тысячи лемингов и то она не у всех работает на нормальной скорости. :p
 

pvvx

Активный участник сообщества
Failed to connect device on /dev/ttyUSB0 !
Uart download server has started...
Только она не отваливается по таймауту, а ждёт чего-то.
Говорит о том что подключения к модулю нет, т.к. они все ждут от модуля кода 'NAK'.
Вы забыли подключить модуль к USB-UART адаптеру, но уже ругаетесь на ПО :)
 

Alexander

Member
Используйте ESP - кто вас принудил брать что-то другое, немного более сложное для вас?
esptool откатывали 7 лет и тысячи лемингов и то она не у всех работает на нормальной скорости. :p
Я же написал, что побудило. Это случается редко, но когда случается - много хлопот.
 

Alexander

Member
Говорит о том что подключения к модулю нет, т.к. они все ждут от модуля кода 'NAK'.
Вы забыли подключить модуль к USB-UART адаптеру, но уже ругаетесь на ПО :)
Это где это я на ПО ругался? :)
Я ругаюсь на модуль, который не переливается по UART. А с OTA я вообще не понял, как оно работает и куда попадёт код.
 

pvvx

Активный участник сообщества
Это где это я на ПО ругался? :)
Я ругаюсь на модуль, который не переливается по UART.
Тогда вам надо купить типа такой модуль, но с BW12:
1617630375632.png
В нем всё работает и кнопочки для перевода в режим загрузки есть.
 
Сверху Снизу