Скрыть объявление
На нашем форуме недоступен просмотр изображений для неавторизованных пользователей. Если Вы уже зарегистрированы на нашем форуме, то можете войти. Если у Вас еще нет аккаунта, мы будем рады, если Вы к нам присоединитесь. Зарегистрироваться Вы можете здесь.

Вопрос Не получается связаться с TCP-сервером на ESP8266. Что может быть не так?

Тема в разделе "Прошивки esp8266 - общие вопросы", создана пользователем Jabberwocky, 11 авг 2016.

  1. Jabberwocky

    Jabberwocky Новичок

    Сообщения:
    7
    Симпатии:
    0
    Всем добрый день!
    Осваиваю ESP 8266. Подключил модуль через usb-to-ttl 3.3В, залил на него прошивку версии 0.9.2.2 через Flasher, всё успешно. AT-команды выполняются, частота изменяется, к wifi-точке доступа модуль подключается, к нему тоже подключиться можно.
    Команда создать сервер проходит, AT+CIFSR возвращает 2. Попытка подключиться через утилиту SocketTest даёт "connection timed out: connect". Файрвол выключен. В чём может быть проблема?..
     
  2. Сергей_Ф

    Сергей_Ф Moderator Команда форума

    Сообщения:
    2.162
    Симпатии:
    226
    @Jabberwocky расскажите для начала, как запитан модуль, какие выводы и как подключены/притянуты и что за прошивка.
     
  3. Jabberwocky

    Jabberwocky Новичок

    Сообщения:
    7
    Симпатии:
    0
    Модуль ESP-01, конвертер USB-TTL YP-02 (CH340) 5V
    Подключение:
    ESP VCC и CH_PD -> (через преобразователь 5v->3.3v) -> USB-TTL 5V
    ESP GND -> (через преобразователь 5v->3.3v) -> USB-TTL GND
    ESP RX -> USB-TTL TX
    ESP TX -> USB-TTL RX
    ESP GPIO0 - не подключен
    У USB-TTL на 3V3 и VCC стоит перемычка, вроде всё)
    Прошивка ESP_8266_v0.9.2.2 AT Firmware, Vendor: ai_thinker.com, AT+GMR возвращает 0018000902
    Всё вот по этой статье делаю: Работа с ESP8266: Первоначальная настройка, обновление прошивки, связь по Wi-Fi, отправка-получение данных на ПК
     
  4. Jabberwocky

    Jabberwocky Новичок

    Сообщения:
    7
    Симпатии:
    0
    Есть какие-то предположения, что-нибудь?...
     
  5. Сергей_Ф

    Сергей_Ф Moderator Команда форума

    Сообщения:
    2.162
    Симпатии:
    226
    @Jabberwocky проверьте преобразователь, под нагрузкой 400 мА (резистор 5-6 Ом) должно быть 3.3 В и без нагрузки не более 3.7 В. Если провода питания от преобразователя до Есп длинные, поставьте танталовый конденсатор ( 47+ мкФ) на входы есп. Попробуйте другой модуль, может брак. Если другого модуля нет, попробуйте прошивку поменять. Но не факт, что поможет.
     
    Последнее редактирование: 12 авг 2016
    Jabberwocky и Victor нравится это.
  6. Jabberwocky

    Jabberwocky Новичок

    Сообщения:
    7
    Симпатии:
    0
    @Сергей_Ф , спасибо за рекомендации, буду пробовать! Правда, у меня первые мысли были не о железе, а о программных причинах (с прошивкой, или с драйвером). Всё-таки часть функционала работает
     

Поделиться этой страницей