Нужна помощь Не работает реле - ESP8266-01

Sergey_Petrov

New member
Помогите разобраться.
Задача: сделать модуль на ESP8266-01 + 3 датчика DS18 + реле на 220в.

Прошивка работает (уже был реализован модуль на китайском реле с типа опторазвязкой, но модуль вис примерно раз в суттки, т.е. прошивка работает, ESP - рабочая).

Сделал такую схему:


Собрал на макетке - все работает.
Сделал плату, запустил - не работает. Нашел, что забыл на эмиторе транзистора подпоять массу. Подпоял. Запускаю - не работает.

Переместился на макетку. Вместо реле поставил светодиод. При включении как-то хаотично моргает и тишина. ESP не виснит. Не могу понять, что произошло. Может сгорел оптрон (4N25)? Как его проверить?
 

Sergey_Petrov

New member
Посмотрите какой номинальный ток светодиода должен быть у 4N25 и какой у вас, блок питания тянет?
Как проверяете?
Блок питания: 5в 1А, ну и на 3,3В на базе LM1117 700mA. Должно хватать. Когда был старый рабочий вариант, который зависал, питал вообще от двух зарядок от мобил по Амперу. Зависал, как от срабатывания реле. Реле если не срабатывае - то не зависает, если пускает реле, то с раза 100 виснет.

А резистор последовательно со светодиодом - не забыли?
Последовательно.
Да и реле похоже себя ведет.
 

kab

New member
раза 100 виснет.
тут недавно был "разбор полётов" - тоже висло после неск. сот срабатываний. Выяснили, что из-за ошибки в коде уменьшалась доступная память. В принципе, несложно определить функцией и вывести, например, в сериал.
 

Sergey_Petrov

New member
тут недавно был "разбор полётов" - тоже висло после неск. сот срабатываний. Выяснили, что из-за ошибки в коде уменьшалась доступная память. В принципе, несложно определить функцией и вывести, например, в сериал.
Может быть. Но я пользуюсь конструктором (сайт наверное нельзя писать, но думаю многие знают его, автор - MaksMS), вроде народ не жалуется. Недоверяю опторазвязке от китайцев + длинные провода 220В.
 

kab

New member
Может быть. Но я пользуюсь конструктором (сайт наверное нельзя писать, но думаю многие знают его, автор - MaksMS), вроде народ не жалуется. Недоверяю опторазвязке от китайцев + длинные провода 220В.
Выше уже советовали померить в ключевых точках мультимером. Ничего умнее уже никто не скажет...
 

=AK=

New member
Собрал на макетке - все работает.
Сделал плату, запустил - не работает. Нашел, что забыл на эмиторе транзистора подпоять массу. Подпоял. Запускаю - не работает.

Переместился на макетку. Вместо реле поставил светодиод. При включении как-то хаотично моргает и тишина. ESP не виснит. Не могу понять, что произошло. Может сгорел оптрон (4N25)? Как его проверить?
Выкиньте оптрон. Он в вашей схеме вообще не нужен, лишняя деталь, от него никакой пользы, один вред. Соедините R2 и R8 напрямую, без оптрона, должно работать.
 

Sergey_Petrov

New member
Выкиньте оптрон. Он в вашей схеме вообще не нужен, лишняя деталь, от него никакой пользы, один вред. Соедините R2 и R8 напрямую, без оптрона, должно работать.
Оптрон не хочется выкидывать. Задача была как раз изолировать две цепи.
 

Sergey_Petrov

New member
Сегодня куплю новый оптрон. Подозрение, что он накрылся - я так понимаю на выходе (на высокой стороне) это транзистор. База - Эмитер и База - Коллектор прозваниваются в обе стороны. Я так понимаю такого не должно быть.
 

=AK=

New member
Оптрон не хочется выкидывать. Задача была как раз изолировать две цепи.
Ну и как же это вы их изолировали, если они гальванически связаны? Что есть оптрон, что нету - все равно связаны.

Выкиньте оптрон, я вам совершенно серьезно говорю. От зависаний он не поможет. Одинаково будет зависать и с оптроном и без него.

Ваше устройство сложно сделать чтобы оно не зависало. Оно будет зависать, потому что у вас, судя по всему, снаружи висит на длинных проводах гирлянда датчиков 1-wire, и заведенa эта антенна для ловли помех это прямо на пин микроконтроллера. Вот где надо было бы развязку ставить. А вы ставите ее туда, где никаких помех вообще нет. Ставите потому что думаете: "раз зависает при срабатывании реле, значит, помеха от реле идет назад по цепи, которой реле включается". А это неверно. Помеха от реле сначала гуляет по сетевым проводам, потом подхватывается длинными проводами гирлянды датчиков и прямым ходом подается вами на ничем не защищенный пин микроконтроллера.

Выкиньте этот оптрон.
 

Sergey_Petrov

New member
Ну и как же это вы их изолировали, если они гальванически связаны? Что есть оптрон, что нету - все равно связаны.

Выкиньте оптрон, я вам совершенно серьезно говорю. От зависаний он не поможет. Одинаково будет зависать и с оптроном и без него.
Буду пробовать. Спасибо.
А как же гальванически развязать? Как защитить не защищеный пин контроллера?
А если на провода датчиков повесить на входе ферритовое кольцо?
 

gerkimuyda

New member
[inline]РежимВключенияШерлокаХомса=Вкл.[/inline] [inline]РежимВключенияКапитанаОчевидность=Выкл.[/inline]
Вы имеете ввиду ультразвуковые радары DS18 для парковки задним ходом?
он имеет внешний интерфейс подключения?
Или фотоэлектрические сенсоры DS18 фирмы Banner?
- там 4 ножки, а не 3, и резистором подтягивать не надо.
Или датчики температуры DS18S20?
зачем S, если в B бит больше и они распространеннее? o_O
 

CodeNameHawk

Moderator
Команда форума
Для проверки закоротите 4 и 5 ноги оптрона, реле должно сработать. Не помешало бы в это время смотреть, что выдает есп на Тх, нет ли перегрузок есп.
Китайское реле с опторазвязкой уже несколько лет работает нормально, но оно обычно рассчитано на работу с 5В, поэтому для нормальной работы стоит реле питать от 5в (как у вас и сделано), перемычку питания снять, но нужно заменить резистор в цепи светодиода.
Попробуйте реле запитать от отдельного источника 5В.
Если DS18 это датчики температуры и у них длинные провода, попробуйте подпаять резистор на 2 к параллельно к R4.
Номинал резистора R8 у вас большой, попробуйте заменить на 200 ом.
Из расчета 2.7 В (лог. единица есп) - 1.15 В (падение на светодиоде оптрона, при токе 10 ма) делим на рекомендуемый ток светодиода 10 ма получаем 155 Ом.
 

Sergey_Petrov

New member
Вы имеете ввиду ультразвуковые радары DS18 для парковки задним ходом? Или фотоэлектрические сенсоры DS18 фирмы Banner? Или датчики температуры DS18S20?
Датчик температуры.

Купил новую оптопару (все же хочу с ней добить схему).
Новая звонится по другому - в одну сторону прозванивается, в обратную - нет, и сопротивление на прозвоне 1кОм, а не 36 Ом.
Поставил новую оптопару - чудо, светодиод горит. Но чудо длилось не долго, через 1 минуту потух, и еще через мгновения хаотично стал мигать. Транзистор поменял на новый - все тоже самое. Не могу понять, что присходит, не хватает знаний электротехники. Буду идти на форум по электротехнике.
Управляющее напряжение (GPIO3) - 3,35 В, после сопротивления 1кОм и в цепи оптопары - 1,1В. Может не хватает силы тока GPIO?
 
Сверху Снизу