Скрыть объявление
На нашем форуме недоступен просмотр изображений для неавторизованных пользователей. Если Вы уже зарегистрированы на нашем форуме, то можете войти. Если у Вас еще нет аккаунта, мы будем рады, если Вы к нам присоединитесь. Зарегистрироваться Вы можете здесь.

Не включается WiFi после прошивки Esp Easy

Тема в разделе "Общие вопросы по esp8266", создана пользователем Oleg_N, 24 мар 2019.

  1. Oleg_N

    Oleg_N Новичок

    Сообщения:
    5
    Симпатии:
    0
    Здравствуйте, уважаемые участники сообщества!

    Пытаюсь сделать подобие "Умного дома" для дачи на наших любимых модулях. Для реализации выбрал знакомую многим прошивку Esp Easy - очень понравился функционал и универсальность. Но неожиданно столкнулся с проблемой: модули ESP-01(s) прошиваются готовыми бинарниками и работают на "Ура", а вот модуль NodeMCU с 4МБ памяти после прошивки не создает точку доступа, хотя в порт пишет "AP mode SSID will be ESP_Easy_0 with adress 192.168.4.1". Пытался прошивать и ESP.Easy.Flasher - ом, и NODE MCU Flasher - ом - результата нет. При этом, при прошивке других скетчей через ArduinoIDE прекрасно работают и режим AP и STA. Пробовал заливать Webupdater из примеров библиотеки, подключаться к роутеру и заливать прошивку Esp Easy через WiFi - ответ "Update OK", но после перезагрузки модуль отваливается от WiFi и АР не создаёт. Заливать перед прошивкой blank пробовал несколько раз - не помогает. Может, у кого будут соображения?
    Да, пару раз точка ESP_Easy_0 после прошивки появлялась на несколько секунд, но после попытки подключиться к ней немедленно пропадала.
     
  2. nikolz

    nikolz Гуру

    Сообщения:
    3.960
    Симпатии:
    426
    у этого модуля ESp-12 надо загрузить параметры wifi по другому адресу чем ESP-01. Возможно вы его стерли или затерли.
    это специальный файл он обычно с прошивками не идет есть в bin в SDK
     
  3. Oleg_N

    Oleg_N Новичок

    Сообщения:
    5
    Симпатии:
    0
    Я подозревал что-то подобное, один раз я попытался залить скетч, по ошибке выставив размер флеш 1 МБ. После этого при старте модуль стал выдавать csum err. Но после заливки flesher - ом blank и загрзке скетча из Arduino IDE все вроде восстановилось. Оказалось, не всё. SDK я скачал, речь, видимо, идёт об esp_init_data_default.bin?
     
  4. Oleg_N

    Oleg_N Новичок

    Сообщения:
    5
    Симпатии:
    0
    По какому адресу его прошить? И как сделать, чтобы он снова не затерся при перепрошивке?
     
  5. nikolz

    nikolz Гуру

    Сообщения:
    3.960
    Симпатии:
    426
    вот тут все подробно есть
    Flashing the firmware - NodeMCU Documentation
     
  6. Oleg_N

    Oleg_N Новичок

    Сообщения:
    5
    Симпатии:
    0
    Прошил esp_init_data_default.bin по адресу 0x3FC000, blank.bin по 0х3FE000 и 0xFEooo,
    затем залил прошивку. Теперь сеть ESP_Easy_0 появляется, но подключиться к ней не удается. Пароль configesp не подходит. Задаю wifissid и wifikey через терминал, save, перегружаю - пишет "STA Mode not configuried".:(:(:(
     
  7. Oleg_N

    Oleg_N Новичок

    Сообщения:
    5
    Симпатии:
    0
    Так и не заработало:(. Уважаемые Гуру, если заглядываете сюда, не подскажете: в SDK 2.2.1 два файла esp_init_data_default : v05 и v08. В чем разница?
     
  8. nikolz

    nikolz Гуру

    Сообщения:
    3.960
    Симпатии:
    426
    оба работают.
    Вы прошейте esp_init_data_default.bin
    потом шейте свою прошивку.
     

Поделиться этой страницей