Не запускается прошивка

nikolz

Well-known member
На boot none при любых настройках SPI_MODE и SPI_SIZE_MAP получается такой же цикл как и у меня раньше

Но на
BOOT = new
APP = 1
SPI_SPEED = 40
SPI_MODE = DIO
SPI_SIZE_MAP = 6
ESPPORT = COM12
ESPBAUD = 115200

В консоль выскакивает

chksum 0x7a
load 0x41f831e8, len -1055784696, room 0
flash read err, ets_unpack_flash_code

И остается в таком виде. Тоже прогресс :)
----------------------------
Посмотрел сейчас,
Оказывается ESP12s имеет 2 МБ ( в одном месте даже встретил что может быть и 1,
а не 4 как ESP12 и ESP12f .
Поэтому надо проверить сколько в вашей флеш.
---------------------------------
Это надо учитывать в адресе 3-го файла и параметра
SPI_SIZE_MAP. (6 и 4 - это для 4MB, а для 2MB - это другие кроме этих )
--------------------------------------
1) Вы собираете и грузите в UDK? или в линуксе пишите свою команду?
2) Поставьте ESPRESSIF DOWNLOAD TOOLS или командной строкой посмотрите параметры flash.
 

Nihalem

New member
----------------------------
Посмотрел сейчас,
Оказывается ESP12s имеет 2 МБ ( в одном месте даже встретил что может быть и 1,
а не 4 как ESP12 и ESP12f .
Поэтому надо проверить сколько в вашей флеш.
---------------------------------
Это надо учитывать в адресе 3-го файла и параметра
SPI_SIZE_MAP. (6 и 4 - это для 4MB, а для 2MB - это другие кроме этих )
--------------------------------------
1) Вы собираете и грузите в UDK? или в линуксе пишите свою команду?
2) Поставьте ESPRESSIF DOWNLOAD TOOLS или командной строкой посмотрите параметры flash.
Получилось. Память была 4мб, все было верно и настройки корректные. Но почему-то при попытке шить flashinit через таргет UDC, вне зависимости от указанной памяти он шьет на 0x7c000 или 0x7e000:
Код:
c:/Espressif/utils/ESP8266/esptool.exe -p COM12 write_flash -ff 40m -fm qio -fs 32m 0x7c000 c:/Espressif/ESP8266_SDK/bin/esp_init_data_default.bin 0x7e000 c:/Espressif/ESP8266_SDK/bin/blank.bin
В документации же которую Вы раньше мне подсказали указано
f you need to customize init data then first download the Espressif SDK 2.1.0 and extract esp_init_data_default.bin. Then flash that file just like you'd flash the firmware. The correct address for the init data depends on the capacity of the flash chip.

  • 0x7c000 for 512 kB, modules like most ESP-01, -03, -07 etc.
  • 0xfc000 for 1 MB, modules like ESP8285, PSF-A85, some ESP-01, -03 etc.
  • 0x1fc000 for 2 MB
  • 0x3fc000 for 4 MB, modules like ESP-12E, NodeMCU devkit 1.0, WeMos D1 mini
  • 0x7fc000 for 8 MB
  • 0xffc000 for 16 MB, modules like WeMos D1 mini pro
See "4.1 Non-FOTA Flash Map" and "6.3 RF Initialization Configuration" of the ESP8266 Getting Started Guide for details on init data addresses and customization.
Попробовал прошить сам через esptool вот так


Код:
esptool.exe -p COM12 -b 115200 write_flash 0x00000 c:/Espressif/ESP8266_SDK/bin/boot_v1.2.bin 0x01000 C:\Espressif\examples\ESP8266\hello_world\firmware\upgrade\user1.4096.new.4.bin 0x3fc000 c:/Espressif/ESP8266_SDK/bin/esp_init_data_default.bin
Иии железка выплюнула мне Hello world в консоль :)

Спасибо большое за помощь и правильные подсказки!
 

Dimak

New member
Приветствую!
Простите новичка, пишу сюда, так как проблема похожая.
Установил UDK по примеру от CHERTS.
Также как и автор темы шью hello_world. Также на скорости 74880 выдаёт похожее сообщение вместо Hello world.
Подправил .makefile проэкта, теперь правильно определяется объём флеша и адресация, но упорно не понимаю как заставить eclipse добавить третий файл (esp_init_data_default.bin) при прошивке и указать ему правильный адрес (0x3fc000).
Подскажите пожалуйста решение.
 
Приветствую!
Простите новичка, пишу сюда, так как проблема похожая.
Установил UDK по примеру от CHERTS.
Также как и автор темы шью hello_world. Также на скорости 74880 выдаёт похожее сообщение вместо Hello world.
Подправил .makefile проэкта, теперь правильно определяется объём флеша и адресация, но упорно не понимаю как заставить eclipse добавить третий файл (esp_init_data_default.bin) при прошивке и указать ему правильный адрес (0x3fc000).
Подскажите пожалуйста решение.
Я добавил в common_nonos.mk вместо
Код:
flashinit:
    $(vecho) "Flash init data default and blank data."
    $(ESPTOOL) -p $(ESPPORT) erase_flash
    $(ESPTOOL) -p $(ESPPORT) write_flash $(flashimageoptions) 0x7c000 $(SDK_BASE)/bin/esp_init_data_default.bin 0x7e000 $(SDK_BASE)/bin/blank.bin
Такой код.
Код:
flashinit:
    $(vecho) "Flash init data default and blank data."
    $(ESPTOOL) -p $(ESPPORT) erase_flash
    $(ESPTOOL) -p $(ESPPORT) write_flash $(flashimageoptions) 0x7c000 $(SDK_BASE)/bin/esp_init_data_default.bin 0x7e000 $(SDK_BASE)/bin/blank.bin 0x3fc000 $(SDK_BASE)/bin/esp_init_data_default.bin
#    $(ESPTOOL) -p $(ESPPORT) write_flash $(flashimageoptions) 0x7c000 $(SDK_BASE)/bin/esp_init_data_default.bin 0x7e000 $(SDK_BASE)/bin/blank.bin

Это для версии UDK v2.2.2 (23.04.2017): (SDK 2.1.0)
 

Dimak

New member
Такой код.
Код:
flashinit:
    $(vecho) "Flash init data default and blank data."
    $(ESPTOOL) -p $(ESPPORT) erase_flash
    $(ESPTOOL) -p $(ESPPORT) write_flash $(flashimageoptions) 0x7c000 $(SDK_BASE)/bin/esp_init_data_default.bin 0x7e000 $(SDK_BASE)/bin/blank.bin 0x3fc000 $(SDK_BASE)/bin/esp_init_data_default.bin
#    $(ESPTOOL) -p $(ESPPORT) write_flash $(flashimageoptions) 0x7c000 $(SDK_BASE)/bin/esp_init_data_default.bin 0x7e000 $(SDK_BASE)/bin/blank.bin

Это для версии UDK v2.2.2 (23.04.2017): (SDK 2.1.0)[/QUOTE]
Спасибо, попробую!
 
Сверху Снизу