Скрыть объявление
На нашем форуме недоступен просмотр изображений для неавторизованных пользователей. Если Вы уже зарегистрированы на нашем форуме, то можете войти. Если у Вас еще нет аккаунта, мы будем рады, если Вы к нам присоединитесь. Зарегистрироваться Вы можете здесь.

Вопрос Проблемы при подключении к роутеру Tp-Link TL-MR3020

Тема в разделе "Общие вопросы по esp8266", создана пользователем RomanMulenkov, 4 апр 2019.

  1. RomanMulenkov

    RomanMulenkov Новичок

    Сообщения:
    6
    Симпатии:
    0
    Доброе время суток.


    Имеется Wemos D1 mini.

    Изначально маршрутизатор был в режиме WISP. Были проблемы и пингом. Провалы были значительные.

    Перевел в режим АР. Пинг нормальный, но стабильно примерно через минуту. Отваливается от WiFi. Если переконектиться опять минуту работает.


    Важно!! со стареньким ТP-link работает нормально. С новым Keenetic тоже.
    TL-MR3020, проверял две железки с разными версиями прошивки. Одинаково плохой пинг.

    Еще момент ESP-01 в той же сетке не отваливается.

    Куда посоветуете копать?
     
  2. enjoynering

    enjoynering Авторитетный участник сообщества

    Сообщения:
    454
    Симпатии:
    49
    давайте начнем от питания. как запитываете Wemos D1 mini.?
     
  3. nikolz

    nikolz Гуру

    Сообщения:
    3.960
    Симпатии:
    426
    У меня MR-3420 и работает без проблем.
    специально для ESP ничего не настраивал
    Полагаю если с интернет проблем нет и Wifi раздается другим устройствам, то роутер не виноват.
     
  4. RomanMulenkov

    RomanMulenkov Новичок

    Сообщения:
    6
    Симпатии:
    0
    Проблемы возникают как при питании от компа так и от аккумулятора. Использует такой шилд.
    [​IMG]
     
  5. Сергей_Ф

    Сергей_Ф Moderator Команда форума

    Сообщения:
    2.126
    Симпатии:
    226
    @RomanMulenkov зачем wemos этот шилд и что он делает? Каковы его характеристики?
     
  6. RomanMulenkov

    RomanMulenkov Новичок

    Сообщения:
    6
    Симпатии:
    0
    Внешний инет не задействован. Только внутренняя сеть. С ESP-01 эти роутеры работали и работают без нарекания. Или я просто не замечал провалы. Возможно для вас не очень актуальна скорость реакции.
     
  7. RomanMulenkov

    RomanMulenkov Новичок

    Сообщения:
    6
    Симпатии:
    0
    Заряд аккумулятора регулировка напряжения , работает как бесперебойник. Нагрузка не большая не думаю, что есть проблемы по питанию. С другими роутерами работа стабильная.
     
  8. nikolz

    nikolz Гуру

    Сообщения:
    3.960
    Симпатии:
    426
    У меня сервер реализован на компе
    Так вот скорость реакции ESP при deep-sleep и обменом по UDP с подтверждением составляет 0.25 сек.
    Ответ сервера как правило приходит через 10 мс.
    А у Вас?
     
  9. Сергей_Ф

    Сергей_Ф Moderator Команда форума

    Сообщения:
    2.126
    Симпатии:
    226
    Ну думайте. Зачем тогда спрашиваете?
     
  10. RomanMulenkov

    RomanMulenkov Новичок

    Сообщения:
    6
    Симпатии:
    0
    Да сервер на компе. Время отклика не замерял. У меня это взаимодействие с человеком, главное чтобы визуально было - сразу.
     
  11. RomanMulenkov

    RomanMulenkov Новичок

    Сообщения:
    6
    Симпатии:
    0
    Я предполагаю, что если ситуация меняется в зависимости от настроек роутера, то возможно нужно изменить параметры соединения в ESP?
     
  12. enjoynering

    enjoynering Авторитетный участник сообщества

    Сообщения:
    454
    Симпатии:
    49
    ошибаетесь. у esp довольно большое пиковое потребление. я никогда не видел стабильную работу модуля с питанием от USB порта и включенным радио. пришлось искать внешний блока 5в 1а чтоб наверняка.
     
  13. nikolz

    nikolz Гуру

    Сообщения:
    3.960
    Симпатии:
    426
    5 вольт и 1 ампер это обычно USB компа. Зачем искать тоже самое
     
  14. enjoynering

    enjoynering Авторитетный участник сообщества

    Сообщения:
    454
    Симпатии:
    49
    да да конечно 5в 1а такое может быть иногда в о-о-очень крайних случаях - у вас дорогая мать, толстые провода и правильно выставлены перемычки на плате (питание USB берется не с дежурки, а с основной линии +5в)

    посмотрите схемотехнику ATX БП и мат плат и помножите это на хлипкие провода до передней моды.

    обычно там 5в 500мА но после тонких проводов с сопротивлением 1 ом/м там и этого не остается.
     
  15. nikolz

    nikolz Гуру

    Сообщения:
    3.960
    Симпатии:
    426
    не возражаю.
    Но замечу следующее.
    Я питаю модули ESP8266 от солнечной панельки 5x8 от двух АА, от двух ААА, и даже от CR2032 и они работают
    т е для работы модуля не нужен источник с током 1 ампер и даже 500 ма
    средний ток потребления 70 ма и источник нужен не более чем на 100 ма.
    Да нужен импульс тока до 300 ма, но его длительность 2 мс между импульсами интервал не менее 10 мс.
    Суммарная длительность этих импульсов при протоколе UDP и пакетах 512 байт не более 10 мс.
    При этом ESP работоспособно при падении напряжения до 2.6 вольта.
    ----------------------
    Это и есть требования к источнику питания
    Т е нужен источник который дает средний ток не менее 80 ма импульсный длительностью до 10 мс не менее 300 ма и при этом допускает просадку на 20%.
    согласитесь что такие требования легко обеспечит USB к которому довешен ASM1117 ,
    а дополнительный импульс тока обеспечивается конденсатором на выходе и конденсатором в источнике USB.
    -----------
    если включать и выключать приемник то средний ток источника можно еще понизить.
    в режиме работы ESP с ожиданием прерываний ток потребления снижается до 3 ма
    ----------------------
    Я это все написал на основе своих измерений и экспериментов.
    Если у Вас есть иные результаты то готов обсудить
    Если же вы будете просто рассуждать на эту тему , то это не интересно и не имеет смысла.
     
  16. Moseich

    Moseich Новичок

    Сообщения:
    37
    Симпатии:
    3
    Вдруг провалы по питанию модуля . по входу питания поставить емкость 200мкф.
     
  17. enjoynering

    enjoynering Авторитетный участник сообщества

    Сообщения:
    454
    Симпатии:
    49
    согласен, но на практике у меня не получилось - ни один usb не отдает импульс 300ма. поэтому и советую 5в 1а чтоб наверняка и без проблем у новичков заработало, а там если если интересно они сами в процессе разберутся со всеми тонкостями.

    с выключенным радио без проблем запускается и работает на любых портах.
     

Поделиться этой страницей