Управляем вентилятором (кулером) РЕШЕНО

Статус
В этой теме нельзя размещать новые ответы.

PAV

Member
@PAV кстати, иногда рекомендуют частоту ШИМ понизить для надёжного старта. Попробуйте 100Гц - будет слышно?
Смех смехом, а шум почти исчез ;) Другой стал, единственное попробовал уйти на 10Hz - писка нет, но вент дергается, если его пальцем остановить, то прям туда-сюда дергается, как будто включают выключают очень быстро (так и есть в принципе)
 

nikolz

Well-known member
Смех смехом, а шум почти исчез ;) Другой стал, единственное попробовал уйти на 10Hz - писка нет, но вент дергается, если его пальцем остановить, то прям туда-сюда дергается, как будто включают выключают очень быстро (так и есть в принципе)
я выше вам написал что возможно резонанс подшипника. Его надо смазать и частота резонанса уйдет
Свист должен изменится если это резонанс ( слышали наверное как трубы водопровода гудят когда кран резонирует).
 

nikolz

Well-known member
у вас в любом случае что-то нет как. На 100 гц работает а на 10000 гц нет, а на 1000 гц что меняется?
 

PAV

Member
у вас в любом случае что-то нет как. На 100 гц работает а на 10000 гц нет, а на 1000 гц что меняется?
Мне сложно судить. На штатной частоте свистит, на 10000 и выше не свистит, но и не работает, если транзистор открыт не полностью.
 

nikolz

Well-known member
Мне сложно судить. На штатной частоте свистит, на 10000 и выше не свистит, но и не работает, если транзистор открыт не полностью.
посмотрите видео выше там есть схема и на осциллографе видно частоту на которой работает.
Сравните схему со своей.
 

PAV

Member
Попробовал другой вентилятор, низкоскоростной, там все тоже самое. Просто тише.
 

PAV

Member

Вот такого плана (из инета), только нет диода у пина и 1WLED(12V) это вентилятор.
 

nikolz

Well-known member

Вот такого плана (из инета), только нет диода у пина и 1WLED(12V) это вентилятор.
зачем светодиод D3? У вас из-за него mosfet возможно и не открывается полностью.
сделайте для тестирования меандр. и переменную частоту и посмотрите диапазон частот управления.
резистор после диода не видно сколько надо не более 100 ом.
На видео включение иначе
 

PAV

Member
А сейчас попробовал совет из инета. Работает, правда выключается при значении ШИМа 600 (3В), но от 600 до 1024 можно играться.
А так можно?ESP8266-FAN2.png
 

Сергей_Ф

Moderator
Команда форума
@PAV можно, но транзистор будет в линейном режиме практически. Будет греться. Это уже не ШИМ.
 

PAV

Member
@PAV можно, но транзистор будет в линейном режиме практически. Будет греться. Это уже не ШИМ.
Греется, зараза. А как в линейном, он же управляет вольтажом, все как надо, только не от 0, а от 600.

Пугает меня, неужели я первый вентилятор к ESP8266 подключаю??? Ну по всему инету крупицы инфы и те не работают!!!
 

nikolz

Well-known member
Греется, зараза. А как в линейном, он же управляет вольтажом, все как надо, только не от 0, а от 600.

Пугает меня, неужели я первый вентилятор к ESP8266 подключаю??? Ну по всему инету крупицы инфы и те не работают!!!
Предположу что у Вас не открывается транзистор полностью особенно на высоких частотах
предположу, что надо либо сделать составной либо сменить MOSFET с более низким порогом.
еще увеличьте резистор, 10 ком например на 100 ком.
уберите емкости нафиг.
 

Сергей_Ф

Moderator
Команда форума
как в линейном, он же управляет вольтажом
Правильно. Но вы повесили RC-цепь на затвор. Какой там сигнал теперь будет? ШИМ - это меандр, а тут будет пила. Будет плавное нарастание и спадание напряжения на затворе. Вот и попадаете на линейный участок ВА-характеристики транзистора.
только не от 0, а от 600.
Да не должен вентилятор от 0 ничего делать. Он даже от постоянных 1 В крутиться не будет. Минимум вольт 4-5 надо, если он на 12 вольт рассчитан.
Вот и сделайте коррекцию программным путем.
А для старта, предусмотрите импульс достаточной продолжительности на максимуме. Потом уже выставляйте скорость.
 
Последнее редактирование:

PAV

Member
Предположу что у Вас не открывается транзистор полностью особенно на высоких частотах
предположу, что надо либо сделать составной либо сменить MOSFET с более низким порогом.
еще увеличьте резистор, 10 ком например на 100 ком.
уберите емкости нафиг.
Нормально все открывается, при 1024 - на выходе положенные 12В, при 0 - 0В
 
Статус
В этой теме нельзя размещать новые ответы.
Сверху Снизу