Обсуждение MT7688AN HLK-7688A

Алексей.

Active member
вообще странно - на сайте роскомпозора openwrt.org и git.openwrt.org не значится. Буду писать провайдеру.
Домен git.openwrt.org резолвится на ip 46.101.214.210 который находится в пуле 46.101.128.0 - 46.101.255.255 принадлежащему Digital Ocean, Inc.
В 18-м году как раз по этой причине мне пришлось переводить инстансы работающие во Франкфурте в другое место. Когда я потерял доступ к ним, сразу обратился к провайдеру, 2-е недели переписывался с поддержкой провайдера, то ОС на моем ПК не та, то логи особенные прислать просят, а через две недели поддержка провайдера сказала что они выполняют требования ген.прокуратуры (блин, мурыжили полмесяца, сказали-б сразу).
Провайдер дал ссылку чтоб я мог сам проверять адреса
 

pvvx

Активный участник сообщества
вообще странно - на сайте роскомпозора openwrt.org и git.openwrt.org не значится. Буду писать провайдеру.
Собственно, необхожимые пакеты могу и на работе утянуть.
Числится. Я как-то выискивал. Там не по имени, а вроде по IP закрыто.
tor обхожу стороной - он же точку выхода может организовать к кого угодно. Потом доказывай, что лошадь не твоя.
Тогда усё - значит Роскомнадзором вам запретил OpenWRT и многое другое. Скоро закроют и все дистры linux. Оставят только Arduino на ESP8266. :)
так а нету бинарника с включенным gcc?
Что за бинарника? Сборки c включенным gcc?
Там инклуюды всех установленных пакетов нужны - а для SPI-Flash это затребует много места...
Присматриваюсь к raspberry pi zero w .... но она мощная, дорогая... NanoPi замороченная....
Без тора - запрещено :)
 

pvvx

Активный участник сообщества
а через две недели поддержка провайдера сказала что они выполняют требования ген.прокуратуры (блин, мурыжили полмесяца, сказали-б сразу).
DNS летом отдавался, а сами IP блокированы с начала года. Эксплорер получает IP, лезет, но ответа не получает.
 

pvvx

Активный участник сообщества
И астру и альт закроют? Не может быть...
Только вчера читал обзор девятой платформы альтлинукса, выпущенной 28.10.2019 (пока используем 8-ю) и уже закроют??
Да я прикалываюсь, но основываясь на реалиях... Не нужно в России ничего - таково желание "элиты". А то представляете, что ваш ребенок будет знать чего-то больше и иметь доступ к запретным знаниям, чем их заграничный ученик. :p
 

parovoZZ

New member
А ещё есть архивчик в докере. Там тоже ссылки уходят на git.openwrt.org? Этот docker в WSL отказался работать - демон не запускается. А в винде мне такого счастья не очень хочется.

NanoPi замороченная....
Да ничего она не замороченная. Даташит адекватный на allwinner. Тулчейн скачал и установил в WSL. Их бы теперь с VSCode поженить... Правда, рекомендуют там кросс-компилятор в докере....черт, опять этот докер....
Ладно, omega пусть подождет...
 

pepelnyy

New member
Господа!
Помогите!
Новичок в Linuxах и OpenWRT.
Прошил вот этим такую плату. Загвоздка в том, что не пойму как запустить WAN. От слова вообще. Потому, что его нет, только LAN все пять портов..
Заранее благодарен!
 

Алексей.

Active member
У меня собрано на рассыпухе, но тот-же mt7688 и столько же флеша и рама, эту прошивку загрузил и немножко настроил.
В настройках сетевых интерфейсов включил "Коммутатор" и немножко поправил сетевые интерфейсы, модуль подключаю wan-ом к другому роутеру, который dhcp раздает из подсети 192.168.1.0/24 из за этого установил для модуля option ipaddr '192.168.33.1' и для wan-а добавил ещё один девайс.
Код:
root@OpenWrt:/# cat /etc/config/network
config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config globals 'globals'
   option ula_prefix 'fd74:442e:378a::/48'

config interface 'lan'
   option type 'bridge'
   option ifname 'eth0.1'
   option proto 'static'
   option ipaddr '192.168.33.1'
   option netmask '255.255.255.0'
   option ip6assign '60'

config device 'lan_dev'
   option name 'eth0.1'
   option macaddr 'b2:85:b4:2a:03:d2'

config interface 'wan'
   option ifname 'eth0.2'
   option proto 'dhcp'

config device 'wan_dev'
   option name 'eth0.2'
   option macaddr 'b2:85:b4:2a:03:d3'

config switch
   option name 'switch0'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'switch0'
   option vlan '1'
   option ports '1 2 3 4 6t'

config switch_vlan
   option device 'switch0'
   option vlan '2'
   option ports '0 6t'

Роутер выдал модулю адрес 192.168.1.44
Код:
root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr B2:85:B4:2A:03:D2 
          inet addr:192.168.33.1  Bcast:192.168.33.255  Mask:255.255.255.0
          inet6 addr: fe80::b085:b4ff:fe2a:3d2/64 Scope:Link
          inet6 addr: fd74:442e:378a::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:5123 (5.0 KiB)

eth0      Link encap:Ethernet  HWaddr B2:58:2B:2A:03:D3 
          inet6 addr: fe80::b058:2bff:fe2a:3d3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2747 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2392 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:352305 (344.0 KiB)  TX bytes:673783 (657.9 KiB)
          Interrupt:5

eth0.1    Link encap:Ethernet  HWaddr B2:85:B4:2A:03:D2 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:5123 (5.0 KiB)

eth0.2    Link encap:Ethernet  HWaddr B2:85:B4:2A:03:D3 
          inet addr:192.168.1.44  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::b085:b4ff:fe2a:3d3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:78 errors:0 dropped:1 overruns:0 frame:0
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:6725 (6.5 KiB)  TX bytes:4016 (3.9 KiB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:352 errors:0 dropped:0 overruns:0 frame:0
          TX packets:352 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:24689 (24.1 KiB)  TX bytes:24689 (24.1 KiB)
 

pepelnyy

New member
У меня собрано на рассыпухе, но тот-же mt7688 и столько же флеша и рама, эту прошивку загрузил и немножко настроил.
В настройках сетевых интерфейсов включил "Коммутатор" и немножко поправил сетевые интерфейсы,
Спасибо! Сегодня вечерком попробую.
 

pvvx

Активный участник сообщества
Если доступ к плате только в консоли и надо включить AP, при первых загрузках до модификаций конфигов в uci и т.д., то требуется ввести всего одну строку вида:
[inline]uci set wireless.@wifi-device[0].disabled=0; uci commit wireless; wifi[/inline]
Источник: Wireless configuration [Old OpenWrt Wiki]
Далее соединиться с AP модуля и в эксплорере работать с UCI страницами...
На разных сборках есть и более короткие пути (консольные команды в меньшее кол-во буковок :) )
 

Алексей.

Active member
Я уж и забыл про неё :)) Судя по активности, тот форум видимо умирает потихоньку.
Только омега немножко собрана как "Device Mode" и свитч там не задействован вовсе.
Пины, которые шарятся с лановскими портами задействованы на другие, цифровые функции.
Заняв только один лановский порт как цифровой, который шарится с SPIS, другие пытался настраивать как аналоговые AGPIO_CFG, но как в дашике сказано
(note: When any bit of bit[20:17] is set to 1, P1 ~ P4 will be swtiched to digital PADs together.)
0: Analog PAD
1: Digital PAD
Как только один настроил как цифровой, остальные отваливаются.
Но это не последний прикол от медиатека.
Настраиваю все линии SPIS как gpio output, начинаю дрыгать линией SPIS_MISO.
Вижу дрыгается не только SPIS_MISO, но и SPIS_MOSI.
Дрыгаю линией SPIS_MOSI, дрыгается только она, опять начинаю дрыгать линией SPIS_MISO и болезнь прошла, дрыгается только SPIS_MISO, а SPIS_MOSI уже не дрыгается как в первом случае.
 

pvvx

Активный участник сообщества
Но это не последний прикол от медиатека.
Ну это второстепенные проблемс...
Основная - OpenWRT полностью построена для UCI. Включая распределение flash и десятки драйверов. Её бы пора переименовать, как система OpenUci :)
Для того чтобы высвободить, очистить от ненужных компонентов и хлама в ядре нужного только UCI требуется не менее года активной работы программиста...
 

pepelnyy

New member
У меня собрано на рассыпухе, но тот-же mt7688 и столько же флеша и рама, эту прошивку загрузил и немножко настроил.
В настройках сетевых интерфейсов включил "Коммутатор" и немножко поправил сетевые интерфейсы, модуль подключаю wan-ом к другому роутеру, который dhcp раздает из подсети 192.168.1.0/24 из за этого установил для модуля option ipaddr '192.168.33.1' и для wan-а добавил ещё один девайс.
Код:
root@OpenWrt:/# cat /etc/config/network
config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config globals 'globals'
   option ula_prefix 'fd74:442e:378a::/48'

config interface 'lan'
   option type 'bridge'
   option ifname 'eth0.1'
   option proto 'static'
   option ipaddr '192.168.33.1'
   option netmask '255.255.255.0'
   option ip6assign '60'

config device 'lan_dev'
   option name 'eth0.1'
   option macaddr 'b2:85:b4:2a:03:d2'

config interface 'wan'
   option ifname 'eth0.2'
   option proto 'dhcp'

config device 'wan_dev'
   option name 'eth0.2'
   option macaddr 'b2:85:b4:2a:03:d3'

config switch
   option name 'switch0'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'switch0'
   option vlan '1'
   option ports '1 2 3 4 6t'

config switch_vlan
   option device 'switch0'
   option vlan '2'
   option ports '0 6t'

Роутер выдал модулю адрес 192.168.1.44
Код:
root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr B2:85:B4:2A:03:D2
          inet addr:192.168.33.1  Bcast:192.168.33.255  Mask:255.255.255.0
          inet6 addr: fe80::b085:b4ff:fe2a:3d2/64 Scope:Link
          inet6 addr: fd74:442e:378a::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:5123 (5.0 KiB)

eth0      Link encap:Ethernet  HWaddr B2:58:2B:2A:03:D3
          inet6 addr: fe80::b058:2bff:fe2a:3d3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2747 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2392 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:352305 (344.0 KiB)  TX bytes:673783 (657.9 KiB)
          Interrupt:5

eth0.1    Link encap:Ethernet  HWaddr B2:85:B4:2A:03:D2
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:5123 (5.0 KiB)

eth0.2    Link encap:Ethernet  HWaddr B2:85:B4:2A:03:D3
          inet addr:192.168.1.44  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::b085:b4ff:fe2a:3d3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:78 errors:0 dropped:1 overruns:0 frame:0
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:6725 (6.5 KiB)  TX bytes:4016 (3.9 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:352 errors:0 dropped:0 overruns:0 frame:0
          TX packets:352 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:24689 (24.1 KiB)  TX bytes:24689 (24.1 KiB)
Урра! Получилось!
 

sbhidden

New member
Есть вопрос к гуру - достался модуль HLK7688a, точнее плата HLK-7688A-SUIT-v1.3
Через WAN-порт не видит TFTP-сервер. Можно ли распаять LAN-порт? (точнее уже распаял на гребенке) и где что включить/выключить? чтобы сменить прошивку?
т.к. линка нет на свиче. Подключал через разъем и транс от старого роутера.
с консоли - не настраивается ввиду:
"[ 0.487885] bootconsole [early0] disabled"
повторюсь.
на гребенку припаяны 2 пары из UTP-кабеля.
с другой стороны приходят к трансформатору от старого неработающего роутера, дорожки, естессно, перерезаны.
коротким патч-кордом (30см) все это подключается в свич. линка на свиче нет.
Для управления доступен только u-boot.
Хочу оживить. Нехватает информации...
 

azt59

Member
Есть вопрос к гуру - достался модуль HLK7688a, точнее плата HLK-7688A-SUIT-v1.3
Через WAN-порт не видит TFTP-сервер. Можно ли распаять LAN-порт? (точнее уже распаял на гребенке) и где что включить/выключить? чтобы сменить прошивку?
т.к. линка нет на свиче. Подключал через разъем и транс от старого роутера.
с консоли - не настраивается ввиду:
"[ 0.487885] bootconsole [early0] disabled"
повторюсь.
на гребенку припаяны 2 пары из UTP-кабеля.
с другой стороны приходят к трансформатору от старого неработающего роутера, дорожки, естессно, перерезаны.
коротким патч-кордом (30см) все это подключается в свич. линка на свиче нет.
Для управления доступен только u-boot.
Хочу оживить. Нехватает информации...
Если Бут работает и принимает выполняет команды по uart то подключайте напрямую lan от платы к lan компа. Компу статический ip, и обязательно отключаете брендмауэр если ос вин7. В бутлоадере обновление через tftp и в бой

How to recover a LinkIt Smart 7688
 

sbhidden

New member
Если Бут работает и принимает выполняет команды по uart то подключайте напрямую lan от платы к lan компа. Компу статический ip, и обязательно отключаете брендмауэр если ос вин7. В бутлоадере обновление через tftp и в бой
Спасибо, что предложили, однако...
Вопрос больше был про то как ВКЛЮЧИТЬ LAN-порт. (не помню где... писали, что внутри есть свой свич)
Потому как, одинаково, при подключении и к свичу, и к компу - линка нет.
Подпайкой разъема с трансформатором внутри уже оживил пару HLK-RM04.
Понимаю что и как программно и аппаратно делается снаружи.
Здесь так запросто не прокатывает. Именно в этом суть вопроса.
Нехватает информации о внутреннем устройстве модуля/процессора.
 

pvvx

Активный участник сообщества
Спасибо, что предложили, однако...
Вопрос больше был про то как ВКЛЮЧИТЬ LAN-порт. (не помню где... писали, что внутри есть свой свич)
Потому как, одинаково, при подключении и к свичу, и к компу - линка нет.
Подпайкой разъема с трансформатором внутри уже оживил пару HLK-RM04.
Трансформатор не обязателен - у вас не 100 метров кабеля соединения.
Вот этом чуде китай-прома https://esp8266.ru/forum/threads/mt7688an-hlk-7688a.2934/page-4#post-65013
нет транса, а по резистору на выход и вход чипа и 2 кондера с каждого резистора на пару в разъеме... Плохо безусловно, но работает.
Понимаю что и как программно и аппаратно делается снаружи.
Здесь так запросто не прокатывает. Именно в этом суть вопроса.
Нехватает информации о внутреннем устройстве модуля/процессора.
Как вы собрались включить то, что может быть отключено в boot?
Полный лог старта вы не привели, а гадать никто не будет.
 
Сверху Снизу