Нужна помощь Ошибка при компиляции для платы NodeMcu 1.0 ESP-12E Module

Не верю, давайте все скриншоты.
Я хотел сказать, что сначала бла такая ошибка:
Third-party platform.txt does not define compiler.path. Please report this to the third-party hardware maintainer.
Ошибка при компиляции: пропущен 'recipe.cpp.o.pattern' параметр конфигурации

Потом удалил само Ардуино ИДЕ и всё что с ней связано. Скачал версию 1.8.9 и версию ЕСП версии 2.2.0 и теперь ошибка такая:

exec: "C:\\Users\\user\\AppData\\Local\\Arduino15\\packages\\esp8266\\tools\\xtensa-lx106-elf-gcc\\1.20.0-26-gb404fb9-2/bin/xtensa-lx106-elf-g++": file does not exist
Ошибка компиляции для платы NodeMCU 1.0 (ESP-12E Module)

Получается, я переустановил программу, та ошибка исчезла, но появилась новая.
 

CodeNameHawk

Moderator
Команда форума
Потому, что у меня диск С завален полностью! На новые версии просто нет меса!
Это пожалуй лучшее объяснение нежелания чего то делать.
Разве не понятно, что при установке старой версии, ей тоже не хватает места, файлов то на диске нет.
Сами винды хотят 10 % свободного места, иначе жуткие тормоза в работе.
Купите новый диск.
 
Последнее редактирование:
Во первых, у меня нетбук! Он сами понимаете закрыт винтами, ставить новый диск не получится!
Во вторых, после вашего сообщения я немного почистил диск С и скачал самую новую версию ЕСП
И в третьих, та же ошибка!
Вот скрины:
 

Вложения

возможно у вас длинный путь и поэтому файл не находится
попробуйте переустановить дурину (каталог Arduino) в корень диска.
т.е не в папку а сразу на диск
Не вышло! Вот скриншот. Выделенные папки Ардуино 15 и сама программа Ардуино и всё это в корне диска С
 

Вложения

Вот в этом и проблема! Загрузить скетч, смог и в порт должен выводиться HTTP адрес но он не выводится. А ещё светодиод на плате тихонько потух после загрузке скетча. Почему? Я просто раньше с ЕСП никогда не работал.
 

Вложения

nikolz

Well-known member
Вот в этом и проблема! Загрузить скетч, смог и в порт должен выводиться HTTP адрес но он не выводится. А ещё светодиод на плате тихонько потух после загрузке скетча. Почему? Я просто раньше с ЕСП никогда не работал.
это другая ошибка
первую вы устранили
возможно не правильно подключили или контакта нет
проверьте работу адаптера
 
это другая ошибка
первую вы устранили
возможно не правильно подключили или контакта нет
проверьте работу адаптера
Не помогло. С адаптером и питанием всё ок. Пробовал менять плату в менеджере на Generic 8266 module но не помогло. С начала долгая загрузка в плату, потом этот скрин, потом 2 скрин, потом открываю порт, но в него ничего не выводится. Единственное, на плате тускло горят 2 светодиода.
 

Вложения

nikolz

Well-known member
Как отправить вам видео с проблемой? Может попробовать в mail.ru? Там быстрый онлайн чат и можно отправлять видео.
по картинкам получается следующее
прошивка в nodemcu загрузилась
но после этого обычно требуется нажать RST кнопку чтобы перезагрузить прошивку
в сообщении это и написано.
 
Сверху Снизу