Прошивка TCP2UART переходника с настройкой по Web

Sergey476

New member
Ну вот и лог и ответ:
У вас кто-то постоянно отключает соединение и меняется IP адрес каждые несколько секунд. :)
PS: а говорили, что настройки всяких штучек в своей сети в специальные не ставили :)
Выкиньте Askey Computer TAIWAN если не можете справиться с его настройками.
Не через несколько секунд, а через 60 секунд .
Выкинул по вашему совету компьютер с 10-го этажа. Правда он оказался не ascey, но неважно.
Теперь подключил по Wifi android , снял лог .
Android тоже выкидывать?
 

Вложения

pvvx

Активный участник сообщества
Не через несколько секунд, а через 60 секунд .
Выкинул по вашему совету компьютер с 10-го этажа. Правда он оказался не ascey, но неважно.
Теперь подключил по Wifi android , снял лог .
Android тоже выкидывать?
Тоже, если настроить не можете. http://macaddress.webwat.ch/hwaddr/8C:18:D9
Не я же разрываю соединение вашего WiFi :)
Там у вас написано: Max connection 1, time waits 0 & 0, min heap size 14528
Т.е. никаких тайм-аутов до отключения соединения по TCP. Но кто-то рвет соединение по WiFi. Не хулиганьте :)
 
Последнее редактирование:

Sergey476

New member
Тоже, если настроить не можете. http://macaddress.webwat.ch/hwaddr/8C:18:D9
Не я же разрываю соединение вашего WiFi :)
Там у вас написано: Max connection 1, time waits 0 & 0, min heap size 14528
Т.е. никаких тайм-аутов до отключения соединения по TCP. Но кто-то рвет соединение по WiFi. Не хулиганьте :)
Сеть состоит из двух устройств esp8266 с с прошивкой UART2TCP и клиента в виде компьютера или планшетника. Так что остаётся только один вариант кто хулиганит. Если это конечно не сговор двух крупных корпораций против UART2TCP
 

pvvx

Активный участник сообщества
У меня (и других) есть множество разных роутеров, свистков, телефонов и разных модулей ESP8266 (у мене десятками разных). Того что пишите на них не наблюдается.
Что можно сказать о последнем китайском модуле, который запихнули вам в Андроид? http://szrfstar.en.alibaba.com/productgrouplist-222377382/Wifi_modules.html :)
Тем более вы до сих пор не назвали какой у вас модуль c ESP8266 и какое он имеет потребление... Может он неисправен... :)
Вот счас, в течении нескольких часов, тестовый модуль ESP8266 соединен с AP и ещё через USB-WiFi свисток. Никаких реконнектов WiFi нет. Стабильно ловит запросы окружающих и не отсоединяется от роутера и сивистка в компе.
Код:
1:02:15.905> Probe Request (MAC:e4:f8:ef:67:f2:53, RSSI:-90)
21:02:16.406> WiFi event 7
21:02:16.406> Probe Request (MAC:00:1c:bf:0d:5d:2c, RSSI:-76)
21:02:16.468> WiFi event 7
21:02:16.468> Probe Request (MAC:00:1c:bf:0d:5d:2c, RSSI:-78)
21:02:21.522> WiFi event 7
21:02:21.522> Probe Request (MAC:84:4b:f5:57:ab:09, RSSI:-91)
21:02:22.646> WiFi event 7
Вот такое с него прет, т.к. тест на SDK 1.4.0.
Иногда, через внутренне установленный период происходит опрос SNTP времени:
[inline]21:06:23.356> SNTP: Set time: 0x55fef59c[/inline]
Других сообщений нет.
TCP2UART при приеме/передаче не передает сообщений в лог, т.к. работает по прерываниям, а скорость вывода сообщений обычно низкая и ей некогда ждать, если работает на 3Mbit/s... TCP2UART выводит в лог только глобальные ошибки и пересоединения.
Для ускорения работы Web до 1 Мегабайта в сек требуется отключать отладочные сообщения. Иначе скорость TCP падает ниж 500 кило в сек, даже если DEBUG UART выставлена на 3 000 000 Baud. Все необходимые установки есть на Веб страничках.
Качество Веб страничек не гарантированно. Там много ошибок - никто не хочет исправлять, а мне всё-равно - редактор есть у каждого :)
За последние пару часов связь по TCP2UART не оторвалась и ошибок пока нет.
Ранее проверялось на сутки...
------
Из лога выходит, что вокруг бродят всякие WiFi и минимальный rssi модуль кажет -97 дБ.
Ранее (на прошлых SDK) в дизасме было найдено, что предельный градусник кажет до -96 дБ, а далее просто нет пересчета...

---
http://esp8266.ru/forum/attachments/ttt-gif.900/
Данное соединение доползло до нескольких мегабайт туда-сюда (там передача по 6 символов через 100 ms) и успешно отвалилось, т.к. модуль был скинут со стола :)
 
Последнее редактирование:

Sergey476

New member
Уважаемый pvvx,
я уже не знаю, преднамеренно или нет, но вы все мои тесты на редкую передачу байтов , пытаетесь заменить на передачу большого потока.Что абсолютно неправильно. У меня на большой скорости ВСЁ РАБОТАЕТ.
Проблема не в компьтер или планшете, а в том что китайский wifi модуль при отсуствии передачи данных на клиента через 60 секунд считает её потеряной.Проблема усугубляется ещё тем,что вы при потери клиента принудительно останавливаете сервер. И тем самым рвёте соединение. Да ещё в тот момент,когда команда закрытия сессии не может дойти до клиента.Если бы вы не останавливали сервер ( как делали в версии 0.1.5 ) то соединение не рвалось бы. И работала значительно устойчивей. Другой способ борьбы с этим -это посылать keepalive пакеты как может делать циска и putty.
 

pvvx

Активный участник сообщества
Уважаемый pvvx,
я уже не знаю, преднамеренно или нет, но вы все мои тесты на редкую передачу байтов , пытаетесь заменить на передачу большого потока..
Да-да 60 байт в секунду это для вас высочайший поток. :)
Проблема не в компьтер или планшете, а в том что китайский wifi модуль при отсуствии передачи данных на клиента через 60 секунд считает её потеряной.
Это действительно неописуемая проблема :) За время передачи байта на 4800 Baud можно открыть новое соединение :)
Проблема усугубляется ещё тем,что вы при потери клиента принудительно останавливаете сервер. И тем самым рвёте соединение. Да ещё в тот момент,когда команда закрытия сессии не может дойти до клиента.Если бы вы не останавливали сервер ( как делали в версии 0.1.5 ) то соединение не рвалось бы. И работала значительно устойчивей. Другой способ борьбы с этим -это посылать keepalive пакеты как может делать циска и putty.
Да я владею навыками "вуды" или как-тама и поселился в ваш модуль. :)
PS: поставил прогу на передачу одного байта в 1 минуту через TCP на COM и 30 секудн в обратную сторону... Полчаса полет нормальный :) Поток неимоверный - 0.016667 байт в секунду :) Думаю, что это бесполезно, т.к. в данном тесте принимают участие только механизмы и вы скажите что необходим "человеческий фактор" :)
---
Прошло 5 часов. Надоело. Остановил. Лог:
Код:
1:06:27.895> srv[12345] 192.168.4.2:13376 [1] listen
1:40:49.683> SNTP: Set time: 0x55ff35f1
2:53:59.051> SNTP: Set time: 0x55ff4716
4:07:11.149> SNTP: Set time: 0x55ff583e
5:20:22.720> SNTP: Set time: 0x55ff6966
6:12:14.468> srv[12345] 192.168.4.2:13376 [1] disconnect
За это время передалось 307 байт в одну сторону и 1224 в другую.
307.gif
@Sergey476 вам наверно опять не понравится, т.к. слишком большой поток? :)
 
Последнее редактирование:

Tomahawk

New member
Sergey476, уже несколько страниц исписали, но так и не понятно чего хотите добиться, на что конкретно, собственно, жалобы. На UART, МК или ТСР. Код открытый, возьмите проанализируйте его, скажите где может быть проблема, а мы посмотрим и сделаем выводы. Я, например, больших проблем пока не заметил, хотя переделывал проект под свои нужды. Что вы хотите от автора? Нужна конкретика. Также нужно иметь ввиду, что не всё зависит от автора, китайское ПО имеет свои недостатки, что нельзя порой так быстро исправить.
 

pvvx

Активный участник сообщества
Sergey476, уже несколько страниц исписали, но так и не понятно чего хотите добиться, на что конкретно, собственно, жалобы. На UART, МК или ТСР.
Пусть жалуется, возможно это приведет к тому, что человек изучит основы "UART, МК или ТСР". Тогда и разберемся.
Хотя уже ясно, что его устройства (если модуль ESP8266 не кривой) включены в энергосберегающий режим и отключают WiFi через 60 сек после бездействия, а стандартно используемые тайм-ауты Sergey476 использовать не хочет.
Так-же в PuTTY наблюдаю сотни установок, которые Sergey476 выставить не желает из-за незнания и требует переноса поддержки по разному стороннему софту и железу на "автора" TCP2UART. Общество потребления и не такие пенки выкидывает... :)
Так-же вижу сплошное непонимание того, что есть другие устройства с аналогичными функциями типа TCP2UART от других изготовителей имеющих десятки лет опыта в этом деле и у меня нет никакого желания лишить их работы, заместив их изделия устройством за 150 рупь. (“Без труда не вынешь и рыбку из пруда”).
 
Последнее редактирование:

AlekseyK

New member
Добрый день!
Подскажите, можно ли на этой прошивке настроить два модуля на "прозрачную" передачу данных, например один AP другой STA, чтоб типа как простые радиомодемы?
А если конкретнее, есть Modbus Master и 1 Slave (RS232 или RS485), хочу вместо провода поставить 2 шт ESP82666
 

Romsb

New member
Организация туннеля UART-WiFi-UART на двух модулях с помощью прошивки Web и AT.
На Web ставим таймауты в TCP-UART Setting (всё остальное по умолчанию или меняем режим UART на усмотрение), а на AT подаем:
AT+CWMODE=1
AT+CWJAP_DEF="ESP8266","0123456789"
AT+SAVETRANSLINK=1,"192.168.4.1",12345,"TCP"
AT+RST
Скажите пожалуйста для этого туннеля нужна прошивка https://github.com/pvvx/esp8266web ? Если да, то шить надо 0x00000.bin и 0x06000.bin из папки "esp8266web-master\bin"по соотвестствующим адресам?
Или можно использовать прошивку https://github.com/pvvx/esp8266web/releases -
TCP2UART? Или подходит стандартная прошивка AT v0.23 SDK 1.0.1 No Cloud Update 512k
 
Последнее редактирование:

pvvx

Активный участник сообщества
Скажите пожалуйста для этого туннеля нужна прошивка https://github.com/pvvx/esp8266web ? Если да, то шить надо 0x00000.bin и 0x06000.bin из папки "esp8266web-master\bin"по соотвестствующим адресам?
Да.
Или можно использовать прошивку https://github.com/pvvx/esp8266web/releases -
TCP2UART? Или подходит стандартная прошивка AT v0.23 SDK 1.0.1 No Cloud Update 512k
Всё зависит от того, что вам надо. Если хотите использовать AT, то последняя версия официальной прошивки AT есть тут: AT_v0.50 based on esp_iot_sdk_v1.4.0 и обсуждение желательно в разделе Прошивки, основанные на AT командах.
TCP2UART имеет Web интерфейс настроек, а не AT. Та или иная версия TCP2UART имеет разные недочеты и базируются на разных SDK.
https://github.com/pvvx/esp8266web содержит вариант последней текущей версии на SDK 1.4.0. Другие ссылки - это более старые версии.
 

Romsb

New member
Спасибо! Значит с оффициальных прошивок я в WEB интерфейс не попаду, а скорость по умолчанию для UART 115200?
 

Romsb

New member
Мне нужен только туннель "UART-WIFI-WIFI-UART" два мк соедененяются по "UART" через 2 "ESP8266".
 

Romsb

New member
Версия web v0.4.8 220915 сначала работала нормально, а через час начала пропадать сеть WIFI при попытке записать или просмотреть что-либо через WEB.
На другом модуле (оба модуля ESP-07) сразу же после прошивки сеть пропадает, с версией
web v0.4.7 180915 все нормально работает.
 

Romsb

New member
В версии "web v0.4.8c 300915" тоже не могу подключиться по WEB, сначала подключится, а как только пытаюсь попасть на адрес "192.168.4.1", сразу же разрыв соеденения WiFi
Но при этот сами модули по туннелю работают нормально без разрывов (может так быстро коннектятся?).
Хотя может это у меня сами модули бракованные.
 

pvvx

Активный участник сообщества
В версии "web v0.4.8c 300915" тоже не могу подключиться по WEB, сначала подключится, а как только пытаюсь попасть на адрес "192.168.4.1", сразу же разрыв соеденения WiFi
Но при этот сами модули по туннелю работают нормально без разрывов (может так быстро коннектятся?).
Хотя может это у меня сами модули бракованные.
Переключите Sleep Mode: в NONE.
 

Romsb

New member
Да я бы переключил, только как, ведь К web интерфейсу не попасть, сразу же обрыв WiFi, иной раз успевает страничка загрузиться, но потом реконнект WiFi и все по новой.
 

pvvx

Активный участник сообщества
Да я бы переключил, только как, ведь К web интерфейсу не попасть, сразу же обрыв WiFi, иной раз успевает страничка загрузиться, но потом реконнект WiFi и все по новой.
Прошейте всё с нуля или очистите область сохранений конфигурации:
0x79000 - bin/clear_eep.bin
0x7E000 - bin/blank.bin
При первом старте, по умолчанию, SDK включает режим Sleep Mode: MODEM. В нем должно работать (но не всё - есть кое-какие мелочи, не влияющие на простые вещи, описывать долго). Если нет, то значит дело не в модуле.
 

Romsb

New member
Получается, что в версии web 0.47 180915 все работает потому, что SDK там версии 1.3?
С нуля перешивал, перешивал и после замены флэш с 512 на 4 МБ, изменений не было.
 
Сверху Снизу