Скрыть объявление
На нашем форуме недоступен просмотр изображений для неавторизованных пользователей. Если Вы уже зарегистрированы на нашем форуме, то можете войти. Если у Вас еще нет аккаунта, мы будем рады, если Вы к нам присоединитесь. Зарегистрироваться Вы можете здесь.

Не получается прошить ESP-12E

Тема в разделе "Прошивки esp8266 - общие вопросы", создана пользователем espnew, 18 окт 2015.

  1. espnew

    espnew Новичок

    Сообщения:
    6
    Симпатии:
    0
    Добрый день.

    В наличии есть ESP12E , USB-TTL Prolific PL-2303 , питание 3.3 от внешнего блока питания.
    Все подключено по схеме Оптимальное подключение ESP8266 для Arduino IDE (http://esp8266.ru/arduino-ide-esp8266).

    Скорость COM порта выставлена 115200.

    Из Arduino IDE любая программа в ESP загружается без проблем
    Из терминальной программы CoolTerm все работает тоже замечательно , отвечает на AT команды и т.д.

    Но никак и не из какой программы не могу поменять прошивку !!!
    Порт открывает , но прошивку не заливает
    пробовал и FLASH DOWNLOAD TOOL и esp8266_flasher и XTCOM_UTIL - все заканчивается на открытии порта.


    Подскажите , какие изменения нужно сделать в схеме Оптимальное подключение ESP8266 для Arduino IDE, что бы можно было зашить прошивку.

    Я делал изменения - вывод GPIO0 подключил с GND , поставил кнопку reset (замыкать на общий) - все без изменений.

    Какие еще есть рекомендации для ESP12E ?
    что делаю не верно
     
  2. espnew

    espnew Новичок

    Сообщения:
    6
    Симпатии:
    0
    Вот что пишет в лог ESP FLASH DOWNLOAD TOOL при попытке прошиться на 115200
    serial port opened
    Connecting...
    chip sync error.
    com closed
     
  3. Victor

    Victor Administrator Команда форума

    Сообщения:
    2.209
    Симпатии:
    386
  4. espnew

    espnew Новичок

    Сообщения:
    6
    Симпатии:
    0
    Да , я это уже делал

    в программе XTCOM_UTIL порт тоже открывается , но счетчик подключений Try to connect times растет ....

     
  5. Victor

    Victor Administrator Команда форума

    Сообщения:
    2.209
    Симпатии:
    386
    попробуйте передернуть CH_PD именно в этот момент
     
  6. Руслан

    Руслан Новичок

    Сообщения:
    9
    Симпатии:
    0
    У меня подобная проблема. Передёрнуть CH_PD не могу, но передёргиваю VCC во время подключения, всё равно не находит мой ESP.
     
  7. espnew

    espnew Новичок

    Сообщения:
    6
    Симпатии:
    0
    Спасибо за совет , завтра проверю по этому моменту.

    Простое передергивание питания и кнопка Reset мне не помогли .
     
  8. Zanuda

    Zanuda Новичок

    Сообщения:
    9
    Симпатии:
    1
    Тоже перепробовал много прошивальщиков , стабильно шьет FLASH_DOWNLOAD_TOOLS_v1.2_150512 Win 8/32 esp-12q + кнопка на gpio-0 на gnd,нажимаем кнопочку втыкаем в усб и жмем старт ,зарание файлики выставив.
     
  9. espnew

    espnew Новичок

    Сообщения:
    6
    Симпатии:
    0
    Добрый день.

    К сожалению совет "попробуйте передернуть CH_PD" не решил этот вопрос , прошивка так и не прошивается
     
  10. espnew

    espnew Новичок

    Сообщения:
    6
    Симпатии:
    0
    стабильно шьет FLASH_DOWNLOAD_TOOLS_v1.2_150512 Win 8/32 esp-12q + кнопка на gpio-0 на gnd,нажимаем кнопочку втыкаем в усб и жмем старт ,зарание файлики выставив.

    Этот совет помог !!!
    Все прошивается нормально !!!
    Спасибо всем !!!
     
  11. oleg_kazakof

    oleg_kazakof Новичок

    Сообщения:
    1
    Симпатии:
    0
    Мне тоже помог , проблема была точно как описано в начале статьи.
     
  12. da3020

    da3020 Новичок

    Сообщения:
    14
    Симпатии:
    0
    Вопрос новичка:
    У меня есть Wemos. Первая ревизия. Я так понял - это чистый esp-12e с уже готовой обвязкой USB-TTL и питания.
    1. Как мне узнать какая версия прошивки залита в чипе?
    2. По логике вещей я могу обновиться по этой же схеме?
     
  13. Zanuda

    Zanuda Новичок

    Сообщения:
    9
    Симпатии:
    1
    1 запустить терминал хотя бы,смотреть чего после ресета пишет.
    2 да,должно.
     
  14. da3020

    da3020 Новичок

    Сообщения:
    14
    Симпатии:
    0
    1. Пишет на скорости 74880 вот что:
    Код (Text):
    1.  ets Jan  8 2013,rst cause:2, boot mode:(3,6)
    2.  
    3. load 0x4010f000, len 1264, room 16
    4. tail 0
    5. chksum 0x42
    6. csum 0x42
    7. ~ld
     
  15. NutsXXXL

    NutsXXXL Читатель

    Сообщения:
    155
    Симпатии:
    17
    @da3020 прикол в том что после этого сообщения на скорости 74880 сообщения начианают выдаваться на другой скорости скажем 115200
    и залито туда может быть что угодно
    например nodemcu или с командами AT
    и для каждого варианта - свой способ
     
  16. da3020

    da3020 Новичок

    Сообщения:
    14
    Симпатии:
    0
    Перепробовал все типовые скорости - ничего вразумительного не пишет.
     
  17. NutsXXXL

    NutsXXXL Читатель

    Сообщения:
    155
    Симпатии:
    17
    @da3020 так а что шум-мусор какой-то да пишет все таки?
     
  18. da3020

    da3020 Новичок

    Сообщения:
    14
    Симпатии:
    0
    Да. Шум/мусор пишет. Но насколько я понимаю сей шум/мусор и есть вышеприведённое сообщение в соответствующем скорости битовом смещении.
    Ничего нового относительно того сообщения на разных скоростях не видно.
    То есть если бы за скоростью 74800 шла фраза на 115200 я бы её увидел за кракозябрами.
     
  19. NutsXXXL

    NutsXXXL Читатель

    Сообщения:
    155
    Симпатии:
    17
    @da3020 тут в соседней веттке у человека такие же симптомы - похоже модуль толком не прошился.
    неплохо бы залить в модуль известную прошивку и тестить по нормальному
     
  20. da3020

    da3020 Новичок

    Сообщения:
    14
    Симпатии:
    0
    ...а ткните пожалуйста в ту ветку носом меня.
     

Поделиться этой страницей