Прошивка ESP 12

hatul

Member
Сейчас флешером загрузил прошивку v0.9.5.2 AT Firmware. Я уже и не помню где ее взял. В мониторе порта пишет:
ets Jan 8 2013,rst cause:2, boot mode:(3,7)

load 0x40100000, len 816, room 16
tail 0
chksum 0x8d
load 0x3ffe8000, len 788, room 8
tail 12
chksum 0xcf
ho 0 tail 12 room 4
load 0x3ffe8314, len 288, room 12
tail 4
chksum 0xcf
csum 0xcf

2nd boot version : 1.2
SPI Speed : 40MHz
SPI Mode : DIO
SPI Flash Size : 32Mbit
jump to run usererror user bin flag, flag = c
user code done
 

CodeNameHawk

Moderator
Команда форума
Не тупите. Вам все дословно писать?
Сейчас флешером загрузил прошивку v0.9.5.2 AT Firmware.
Светодиод погас?
Покажите реакцию есп на команду АТ в программе hterm , в конце надо послать ввод каретки и перевод на новую строку.
 

hatul

Member
Светодиод погас
Горит.
Я такую программу первый раз слышу. С моим английским мне три дня надо в ней разбираться. А в Ардуино IDE в мониторе на команду АТ нет никакой реакции.
P.S. Я извиняюсь,завтра рано вставать на работу ,поэтому на все дальнейшие посты отвечу завтра.
 

CodeNameHawk

Moderator
Команда форума
На моей плате диод подключен от 3.3в через резистор на GPIO2.
Горит он, если на GPIO2 низкий уровень, вы на GPIO2 намерили высокий уровень.
Ищите проблему где то здесь.
Или измеряете не на той ноге или может быть у вас светодиод на другой ноге, проверяется тестером в режиме прозвонки.
esp12-e_pinouts2.png
Если на GPIO2, во время подачи напряжения питания низкий уровень, есп не сможет загрузить ваш скетч.
Не помешает проверить напряжения и на остальных ногах есп и ну сюда выложить.
 

hatul

Member
проверить напряжения и на остальных ногах
GPIO2 , 4 ,5 , 12 , 13 ,14 , 16 напряжение 2.85 -2.9 вольт.
светодиод на другой ноге
в скетче перепробовал менять все пины. Ни один не горит.
Ну ладно, оставим светодиоды в стороне. Из примеров Ардуино IDE заливаю скетч скетч WIFiAccessPoint . Должна появиться точка доступа. Ничего! Тишина! Этот же скетч заливаю Esp8266 NodeMcu , все нормально , точка доступа появляется. Значит скетч рабочий! Есть еще две ESP 12. В них я еще не заливал ничего. Где то нашел,что для проверки новой платы надо перемкнуть EN на Vcc , a GPIO15 на GMD. При подаче питания должна появиться точка доступа. Попробовал,все нормально,появляется. Плата рабочая! На выходные начну мучать вторую плату.
 

hatul

Member
А второй вывод.
Сначала был на минус. После Вашего поста,что у Вас горит при низком сигнале на ноге поменял. На пин - минус. Плюс на 3.3 вольта. Светодиод погас.Но все равно не моргает. Один раз моргнет,если нажать на Reset. Обнаружил еще вот что. По схеме резисторы для подтяжки пинов 10 ком. Сослепу (старый стал) поставил 1 ком. Сегодня поменял,но похоже уже поздно. Мог я что то спалить на плате?
 
Сверху Снизу