Прошивка TCP2UART переходника с настройкой по Web

Pilowar

New member
UART молчит. Есть ещё нюанс один, при переводе в STATION_MODE клиент пропадает из списка доступных сетей.
Синий диод помигивает.
Ещё заметил при подключении к серверу через WEB IP адрес присвоенный моему компьютеру заканчивается на 3, а 2 должен быть клиентом, но связи по UART нет...
Скриншоты с настройкой приложил, были сняты уже после настройки и перезагрузки.
 

Вложения

shaman1010

Member
адрес присвоенный моему компьютеру
Перечитай, что я тебе выше написал.
подсказака - STA - это режим клиента, AP - точки доступа.
Настраиваешь одну как AP, ее-же сервером, вторую как AP+STA - заходишь на вторую точку доступа (SSID AP1 != SSID AP2) и настраиваешь ее клиентом к AP1. Проверяешь связь, когда все проверишь перенастрой клиента просто в STA, без поднятия второй точки доступа.
 

Bobr

New member
Esp-Link с библиотекой El-Client. Там встроенные сокеты TCP. Стабильность - приемлемая. Вы понимаете, что это решение требует наличие Ардуины? Желательно 328p.
Esp-Link не поддерживает скорость 2400, т.е. в настройках она есть, но если выбрать то 8266 зависает и нужно заново перепрошивать на другую прошивку не Esp-Link...
 
Для тех кому не понятно как установить прошивку в конце видео это есть и делается в течении 2х минут(УРОВЕНЬ ШКОЛЬНИКА и ниже). Также есть тест на примере передачи изображения.
 

Павел777

New member
Добрый день! Прошу помощи у тех немногочисленных людей, кто сюда еще зайдет)
Использую ESP07 с данной прошивкой в режиме клиент+сервер. Стабильно работает около месяца, потом клиент отваливается от сети, а при попытке зайти на веб-морду - как то рандомно меняется логин, поле пароля пустое. Почему могут слетать настройки?
Сбрасываю модуль ногой RX на землю, настраиваю заново и работает еще около месяца. Так уже раза 4 или 5 было.
 

Вложения

aloika

Active member
Добрый день! Прошу помощи у тех немногочисленных людей, кто сюда еще зайдет)
Использую ESP07 с данной прошивкой в режиме клиент+сервер. Стабильно работает около месяца, потом клиент отваливается от сети, а при попытке зайти на веб-морду - как то рандомно меняется логин, поле пароля пустое. Почему могут слетать настройки?
Сбрасываю модуль ногой RX на землю, настраиваю заново и работает еще около месяца. Так уже раза 4 или 5 было.
Это все потому, что ESP8266 использовать не надо, она сама по себе нестабильная. Используйте RTL8710AF, например. Или можно попробовать серию B - RTL8710Bx. Эти модули/чипы гораздо стабильнее.
 

ivanpost67

New member
Добрый день! Прошу помощи у тех немногочисленных людей, кто сюда еще зайдет)
Использую ESP07 с данной прошивкой в режиме клиент+сервер. Стабильно работает около месяца, потом клиент отваливается от сети, а при попытке зайти на веб-морду - как то рандомно меняется логин, поле пароля пустое. Почему могут слетать настройки?
Сбрасываю модуль ногой RX на землю, настраиваю заново и работает еще около месяца. Так уже раза 4 или 5 было.
Используйте прошивку Esp-link. В плане uart она стабильна. есть фичи, типа OTA. https://github.com/jeelabs/esp-link
 

achilles85

New member
Прошил модуль 12E крайней прошивкой. В настройках tcp2uart выставляю скорость 38400, после применения настроек скорость становится 38406. Оборудование, к которому подключен переходник, хочет 38400. Как выйти из положения?
 
Сверху Снизу