Решено сбой в процессе прошивки

reset во время коннекта пробовали дернуть
не пробовал, он просто в воздухе висит, куда и как его правильно подключать? и что значит дернуть? :)
раз 10 проверил
Гляньте еще все таки мой
изучал этот пост перед экспериментами

в общем переделываю сейчас по схеме Виктора(там правда про ресет ничего нет) и отпишусь через полчаса

и еще глупый вопрос: если нужно подключить два входа через одинаковый резистор к земле например можно это сделать через один резистор?
 

JustACat

Moderator
Команда форума
Ну, reset в воздухе - это жесть... Reset активируется нулем, значит подтягивать его нужно к +3.3.
Итого: подключаете Reset через резистор на 1-10 кОм к +3,3 и его же через кнопку (для удобства) на землю. То есть когда кнопка отпущена - Reset тянется резистором к 3.3, а как вы нажимаете кнопку - то сажаете его жестко на 0.
И дернуть - это значит как раз в момент после того, как в XTCOM нажали кнопку, и побежали циферки попыток подключения - вот как раз тогда и дернуть (нажать на кнопку, сбросить). Как-то так.
Можно и с полным отключением питания попробовать, опять же, в момент, когда циферки попыток бегут.
 
А подскажите где посмотреть за что отвечает каждый вывод?
А то я как слепой котенок тыкаюсь...
Пробовал смотреть даташит, но то ли я не то смотрю, то ли там так все зашифровано что у меня разобраться сходу не получилось :(
 

JustACat

Moderator
Команда форума
за что отвечает каждый вывод
В этих 3-х доках по крупицам:
- ESP8266_Specifications_v4.1.pdf
- ESP8266_Beginners_Guide_V0.4.1.pdf
- ESP8266_Module Application Design Guide.pdf
Причем последний больше всего, наверное, подходит. Там и про правильное подключение, и про ноги, более или менее...
Ну и вот эти гляньте:
http://esp8266.ru/esp8266-gpio-registers/
http://esp8266.ru/esp8266ex-pinouts/
http://esp8266.ru/modules-esp8266/

PS: я у вас на фото не увидел толком - питание нечаянно не с USB идет с переходника? Если так - то в этом легко может быть проблема... Его может просто не хватать. Лучше использовать внешний источник питания на 3.3 вольта с запасом, хотя бы mA на 700+...
 

Andy Korg

Moderator
Команда форума
На последнем фото не увидел ни одного блокировочного конденсатора, попробуйте добавить один электролит и один керамический, оба не важно какой емкости.
 
В общем проблемы именно с этим модулем.
Распаял другой и он сразу запустился шаманств: на АТ команды отвечает и появилась открытая точка доступа(AI-THINKER###)
 
перепаял первый и он тоже заработал! и даже без резисторов - видимо где-то плохо пропаял или наоборот кз было.
а что все-таки означает синий светодиод? сейчас он не горит и не мигает при этом модуль вроде как нормально работает.
 

JustACat

Moderator
Команда форума
видимо где-то плохо пропаял или наоборот кз было
Увы, вы не первый, кто столкнулся с проблемой плохого контакта. Но вроде как писать об этом человеку в качестве совета - проблема. Некоторые даже обижаются, мол, "как я мог плохо пропаять, у меня опыт на 10 лет, все дела". А у вас и на вид по фото все прилично (хотя есть подозрения на китайскую лапшу разноцветную, она не всегда хорошая попадается). В любом случае я рад, что у вас все получилось!
Про синий светик вам Inspector ответил.
 
Inspector, JustACat, спасибо.
У меня есть подозрения на неизвестный флюс, который паяет хорошо, но похоже токопроводящий и его надо хорошенько удалять.
А так как опыта паяния у меня почти нет вот и не догадался проверить на кз.
В общем буду паять канифольным флюсом.
 

JustACat

Moderator
Команда форума
Очень может быть. В случае с ESP любого чиха достаточно, чтобы загадить процесс старта, прошивки или общения с модулем...
ЛТИ-120 марки Connector - отличная штука, имхо. Безотмывочный. А еще вот это посоветую почитать: Ликбез по пайке.
 
Сверху Снизу