Скрыть объявление
На нашем форуме недоступен просмотр изображений для неавторизованных пользователей. Если Вы уже зарегистрированы на нашем форуме, то можете войти. Если у Вас еще нет аккаунта, мы будем рады, если Вы к нам присоединитесь. Зарегистрироваться Вы можете здесь.

Делюсь опытом ESP8266, ARDUINO IDE,Примеры

Тема в разделе "Раздел для начинающих", создана пользователем kab, 7 сен 2017.

?

Чем преимущественно пользуетесь для общения с MCU?

  1. Arduino IDE

    33 голосов
    86,8%
  2. LUA

    1 голосов
    2,6%
  3. Пользуюсь готовыми прошивками(кроме LUA)

    2 голосов
    5,3%
  4. Си, SDK и т. п.

    2 голосов
    5,3%
  5. Другое

    0 голосов
    0,0%
  1. tigrgod

    tigrgod Новичок

    Сообщения:
    8
    Симпатии:
    0
    Так вот я нашел товарища который переписал как-то это дело и у него заработало. Мне интересно на основе этого, сможет ли кто-то сказать как?
     

    Вложения:

    • 333.PNG
      333.PNG
      Размер файла:
      33,4 КБ
      Просмотров:
      21
  2. Сергей_Ф

    Сергей_Ф Moderator Команда форума

    Сообщения:
    2.280
    Симпатии:
    238
    @tigrgod ссылку дадите, разберемся. Скриншот-то зачем без исходников?
    Если речь про r-downing/EasySSDP, то там ничего не переписано и нет никакой информации что работают свойства под 10-кой.
     
    Последнее редактирование: 30 дек 2018
  3. CodeNameHawk

    CodeNameHawk Moderator Команда форума

    Сообщения:
    1.745
    Симпатии:
    186
    У меня под win 10 pro работает.
    Из тех скудных данных, что здесь приводят, различие в том, что у меня название есп без пробелов.
    У меня description.xml выдает так

    2.png Untitled.png
     
    Последнее редактирование: 30 дек 2018
  4. tigrgod

    tigrgod Новичок

    Сообщения:
    8
    Симпатии:
    0
    Вот же исходники: Is esp8266ssdp/ssdp working? · Issue #2283 · esp8266/Arduino
     
  5. CodeNameHawk

    CodeNameHawk Moderator Команда форума

    Сообщения:
    1.745
    Симпатии:
    186
    У вас иконка устройства, в сетевом окружении появляется?
    Двойной клик страницу открывает?
    Вполне возможно, что не работает из за установок самой виндовс, типа разрешать обнаруживать устройства в сети.
     
  6. Сергей_Ф

    Сергей_Ф Moderator Команда форума

    Сообщения:
    2.280
    Симпатии:
    238
    Вы ссылку даёте на форум. Исходники где? В сообщении или в теме форума?
    Посмотрю после праздников.
     
  7. Сергей_Ф

    Сергей_Ф Moderator Команда форума

    Сообщения:
    2.280
    Симпатии:
    238
    @CodeNameHawk
    Иконка есть. По клику страница открывается. Но по правой кнопке свойства дают ошибку. Все как описывали выше.
     
  8. CodeNameHawk

    CodeNameHawk Moderator Команда форума

    Сообщения:
    1.745
    Симпатии:
    186
    Сергей_Ф, остается только проверить не закрыт ли порт 1900

    netstat -a выдает
     

    Вложения:

    • rez.txt
      Размер файла:
      5,6 КБ
      Просмотров:
      17
  9. Сергей_Ф

    Сергей_Ф Moderator Команда форума

    Сообщения:
    2.280
    Симпатии:
    238
    @tigrgod а у вас скомпилировалсся этот пример? У меня не хочет - выдает ошибку.
     
  10. Сергей_Ф

    Сергей_Ф Moderator Команда форума

    Сообщения:
    2.280
    Симпатии:
    238
    tigrgod, откатил ядро esp8266 до версии 2.0.0 - скомпилировалась. На что только не приходится идти :)
    Подтверждаю - свойства работают под 10-й виндой. И даже иконка своя. Буду разбираться что и как. Спасибо за наводку, надеюсь мне это тоже пригодится :)
     
  11. ВладимирИзКостромы

    ВладимирИзКостромы Новичок

    Сообщения:
    20
    Симпатии:
    0
    Всем доброго дня.
    Если еще актуально. во вложении рабочая версия библиотеки представленной выше и скетч к ней. компилируется и работает на ядре 2.5.2.
    Но есть 2 проблемы
    1. Работает только если порт указан 80. на любом другом устройство не отображается
    2. Обнаружение в Вин10 зависит от сборки.
    у меня дома 2 компа на обоих винда 10 но установленная в разное время и с разных дистрибутивов. таким образом на более старом дистрибутиве устройство обнаруживается (так же обнаруживается включенный телевизор подключенный к этой же сети), а вот на свежем нет (точнее не совсем нет) в сети этого устройства нет (но нет и телевизора подключенного в эту же локальную сеть), а вот при запуске программы Домашний медиацентр, видно и телевизор и ESP

    Если кто то найдет решение 2-х данных проблем, буду благодарен.
    по второму вопросу переустановка винды невозможна.
     

    Вложения:

    • MySSDP.zip
      Размер файла:
      5,3 КБ
      Просмотров:
      1
  12. CodeNameHawk

    CodeNameHawk Moderator Команда форума

    Сообщения:
    1.745
    Симпатии:
    186
    Что установили под виндовс, что бы было видно.
     
  13. CodeNameHawk

    CodeNameHawk Moderator Команда форума

    Сообщения:
    1.745
    Симпатии:
    186
    И второй вопрос чем стандартный SSDP не нравиться?
     
  14. ВладимирИзКостромы

    ВладимирИзКостромы Новичок

    Сообщения:
    20
    Симпатии:
    0
    вот этого не могу сказать. т.к. разные установки на разных компах.

    тем что он не обнаруживается под вин 10 в принципе.даже под старыми сборками.

    эта версия на одной сборке обнаруживается в момент старта esp. стандартная вообще не обнаруживается
     
  15. CodeNameHawk

    CodeNameHawk Moderator Команда форума

    Сообщения:
    1.745
    Симпатии:
    186
    Соберите скетч из стандартного примера, добавьте одну строчку, как описано выше.
    Покажите настройки сети и адреса есп и компа (скриншотами).

    Poisk.png Status.png
     
  16. ВладимирИзКостромы

    ВладимирИзКостромы Новичок

    Сообщения:
    20
    Симпатии:
    0
    адрес ESP 192.168.0.23
    компа 192.168.0.62
    Screenshot_1.png Screenshot_2.png Screenshot_3.png
     
  17. ВладимирИзКостромы

    ВладимирИзКостромы Новичок

    Сообщения:
    20
    Симпатии:
    0
    Сейчас перепроверил типовой пример. Все работает. определение на ноуте произошло. но основной комп так и не видит. понимаю что дело в винде. но как решить эту проблему не знаю пока. Да и вопрос с портом кроме 80-го остается открытым. при указании в типовом примере порта например 81. определение уже не работает.
     
  18. CodeNameHawk

    CodeNameHawk Moderator Команда форума

    Сообщения:
    1.745
    Симпатии:
    186
    А с чего вы взяли, что на 81 порту должно работать?
    Комп как узнает, что вы поменяли порт? Да и зачем вам это?
     
  19. CodeNameHawk

    CodeNameHawk Moderator Команда форума

    Сообщения:
    1.745
    Симпатии:
    186
    Не обязательно, что дело в винде.
    Был у меня роутер, так в нем LAN и WiFi сети были взаимонедоступны, помогла пере конфигурация роутера.
     
  20. ВладимирИзКостромы

    ВладимирИзКостромы Новичок

    Сообщения:
    20
    Симпатии:
    0
    Ну например есть у меня телевизор подключенный к роутеру КАБЕЛЕМ. и его комп тоже не видит, а ноут видит
    А что касаемо порта. ну тот же телевизор висит на порте 49153 ион на ноуте виден, хотя что интересно в файле описания нет базового адреса , да и адрес описания своебразное имя имеет.

    По-поводу зачем мне это. Ну могу сказать так мне хочется чтобы было так. Если в других случаях это работает то почему тут не получается.
    А так программирую управление индукционной плиткой, которое необходиммо контролировать из вне т.е. вне дома. а вот с 80 портом на роутере при переадресации какой то трабл. когда ЕСП запускаю на 81-м там без проблем переадресация IP внешнего происходит. а когда на 80-м, почему то через раз. так то мне не принципиально на каком порту будет. да и в принципе не принципиально чтобы это отражалось как сетевое устройство. Просто хочется понять и разобраться. не более того
    Screenshot_4.png Screenshot_5.png
     

Поделиться этой страницей