ESPlorer

Nercs

New member
Пробую ат команды sim900 в esplorer.
Заметил такую штуку - нельзя отправить непечатные символы, например char(26) ни в таком виде ни в hex.
Понимаю что программа заточена под еспшку, но можно и добавить АТ команды для сим и кнопку отправлять hex
 

Gooman

New member
Помогите, пожалуйста. Получил сегодня nodemcu плату. Подсоединил к ноутбуку, драйвера поставились сами. Прошивка прошилась без проблема. Однако в ESPLorer не могу соединиться с платой. Номер порта esplorer определил такой же, как и при прошивке. Однако, когда я нажимаю кнопку Open, то в консоли просто пишет
Код:
PORT OPEN 9600

Communication with MCU..
И больше ничего не пишет.

Понажимал кнопки DTR и CTS и что-то заработало!
 

Nercs

New member
Помогите, пожалуйста. Получил сегодня nodemcu плату. Подсоединил к ноутбуку, драйвера поставились сами. Прошивка прошилась без проблема. Однако в ESPLorer не могу соединиться с платой. Номер порта esplorer определил такой же, как и при прошивке. Однако, когда я нажимаю кнопку Open, то в консоли просто пишет
Код:
PORT OPEN 9600

Communication with MCU..
И больше ничего не пишет.

Понажимал кнопки DTR и CTS и что-то заработало!
Попробуйте сначала открыть порт, потом вкл-выкл устройство.
 

newload

New member
Помогите, пожалуйста. Получил сегодня nodemcu плату. Подсоединил к ноутбуку, драйвера поставились сами. Прошивка прошилась без проблема. Однако в ESPLorer не могу соединиться с платой. Номер порта esplorer определил такой же, как и при прошивке. Однако, когда я нажимаю кнопку Open, то в консоли просто пишет
Аналогичная проблема. И ее решение пока что не нашел. В чем может быть причина?
 

Gooman

New member
Аналогичная проблема. И ее решение пока что не нашел. В чем может быть причина?
Не знаю, в чем причина. Рекомендую подключить nodemcu к компьютеру, выбрать правильнй com порт из списка и понажимать кнопки DTR и CTS в программе, пока не появится что-либо в консоли.
 

nikolz

Well-known member
Помогите, пожалуйста. Получил сегодня nodemcu плату. Подсоединил к ноутбуку, драйвера поставились сами. Прошивка прошилась без проблема. Однако в ESPLorer не могу соединиться с платой. Номер порта esplorer определил такой же, как и при прошивке. Однако, когда я нажимаю кнопку Open, то в консоли просто пишет
Код:
PORT OPEN 9600

Communication with MCU..
И больше ничего не пишет.

Понажимал кнопки DTR и CTS и что-то заработало!
Так бывает часто. Надо нажать reset на плате
 

Brainy

New member
Всем привет,

Имеется модуль ESP8266 12F
Прошку ставил с сайта nodemcu-build.com, и так же esp_init_data_default.
Прошивал СH340G, прошивка стала.

В самом Esplorer, могу подключиться тока по порту 115200 и выдаёт 1.jpg
При других значениях порта, не происоходит вообще нечего.

Смог залить прошивку BLINK, но не могу залить не одну другую при подключении GPIO13 к датчику DHT11 выдаёт Waiting answer from ESP - Timeout reached. Command aborted.
Что не так делаю ?
 

Вложения

  • 49.8 KB Просмотры: 51

NeoroN

Member
Вот еще вопрос, можно ли сделать так чтобы в логе можно было писать как в консоли а то это окошко внизу и кнопка сенд - вызвают неудобство. Оставить ее только для режима когда в HEX виде лог. Я конечно могу это сделать для себя, но больше времени уйдет чтобы эклипс с ant подружить.
 

Romchik

New member
Привет! Извините за нубский вопрос, но я просто не нашел полного описания по ESPlorer и прочитал всю эту тему, не могу понять с чего начать и как пользоваться, для меня тема новая, в интернете про пользование ESPlorer почти нет информации, в основном все уже умеют...
Я не могу понять для чего snippets нужны и как ними пользоваться.
Написал в один snippet код для подключения к точке доступа и запустил его:
Код:
wifi.setmode(wifi.STATION)
wifi.sta.config("INTERNET","12345678")
wifi.sta.autoconnect(1)
Теперь контроллер подключается к сети при включении, даже без ESPlorer!
Хотел это написать в init.lua, теперь вижу что в этом нет необходимости, проверяю память, ничего не занято! Непонятно куда записалась информация или я чего-то не понимаю?
 

eeciv

New member
ESPlorer не соединяется с sonoff basic прошитой nodemcu. Прошивал nodemcu флэшером. Игрался с разными скоростями на портах, пробовал шиться как usb-ttl, так и через arduino. При этом модуль стартует - появляется wi-fi базовая станция, а связи с esplorer нет. Другие альтернативные прошивки(wifi-iot, sonoff-tasmota) на модуле работают. Подскажите плз куда еще смотреть.
 

Greg

New member
Здравствуйте,
My Russian is extremely basic so forgive me posting in English.
I didn't see this on esplorer's github page, so I will post an info here.

So, ESPlorer crashes while trying to establish connection with NodeMCU. It is probably because of Java9 (build 9+181).
The exception says:

# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000007110b5db, pid=12320, tid=16832
# Problematic frame:
# C [jSSC-2.8_x86_64.dll+0xb5db]

Jvm config:
# Java VM: Java HotSpot(TM) 64-Bit Server VM (9+181, mixed mode, tiered, compressed oops, g1 gc, windows-amd64)

Thread dump:
--------------- T H R E A D --------------- Current thread (0x000002686f4c2 - Pastebin.com

When I run ESPlorer in Java8 it works perfectly.
 
Сверху Снизу