Скрыть объявление
На нашем форуме недоступен просмотр изображений для неавторизованных пользователей. Если Вы уже зарегистрированы на нашем форуме, то можете войти. Если у Вас еще нет аккаунта, мы будем рады, если Вы к нам присоединитесь. Зарегистрироваться Вы можете здесь.

Прошивка esp8266 с помощью xtcom_util

Тема в разделе "FAQ для новичков", создана пользователем Victor, 14 фев 2015.

  1. Victor

    Victor Administrator Команда форума

    Сообщения:
    2.211
    Симпатии:
    386
    попробуйте во время этого процесса отключить CH_PD от питания и снова подключить обратно (чип при этом перезагружается)
     
    slavas нравится это.
  2. slavas

    slavas Новичок

    Сообщения:
    2
    Симпатии:
    0
    не отправляются команды через putty и CoolTerm. открывается окно putty и мигает курсор (ничего не вводится). что может быть?
     
  3. AndreyD

    AndreyD Читатель

    Сообщения:
    22
    Симпатии:
    6
    Добрый день, приобрел ESP-01. С родной прошивкой реагировал на AT команды.

    Решил залить с помощью XTCOM_UTIL прошивку https://github.com/nodemcu/nodemcu-firmware/releases

    Девайс прошивается, т.е. в результате XTCOM_UTIL выдает
    upload_2015-8-26_12-58-59.png

    Отключаю GPIO0 от нуля, передергиваю питание ESP-01 и Windows XP выдает, что устройство USB не распознано (диод горит более тускло, чем при прошивке)

    В чем проблема?

    Пробовал последние прошивки float и integer заливать на разных скоростях все одно и то же. Пробовал резетить, тоже не помогает.

    Через NodeMCU Flasher тот же результат.


    Проблема решилась установкой Flash Speed в 20MHz при прошивке в NodeMCU Flasher.
     

    Вложения:

    Последнее редактирование: 26 авг 2015
  4. Victor

    Victor Administrator Команда форума

    Сообщения:
    2.211
    Симпатии:
    386
    это отваливаются драйвера вашего USB-TTL конвертера из-за нехватки питания (просаживается 5в на USB шине)
    Запитайте ESP8266 отдельным источником питания, который точно держит 300мА 3,3v
     
  5. AndreyD

    AndreyD Читатель

    Сообщения:
    22
    Симпатии:
    6
    А почему тогда после прошивки с Flash Speed в 20MHz все нормально работает при той же схеме подключения?

    PS. капризная железка все-таки, я пока без резисторов и кондёра собрал - перезагружается время от времени ))
     
  6. Victor

    Victor Administrator Команда форума

    Сообщения:
    2.211
    Симпатии:
    386
    да, штучка капризная, требует аккуратности

    Точно сказать не могу (скорее всего в этом случае ESP8266 имеет меньшее потребление), но могу точно сказать другое:
    Драйвера "видят" только USB-TTL конвертер и им абсолютно без разницы что подключено дальше. Попробуйте, например, вообще отсоединить ESP8266 - ничего не изменится.
    Но вот если подключить к USB-TTL конвертеру (или просто к шине USB) нагрузку, которая будет потреблять большой ток, то драйвер отвалится.
     
  7. AndreyD

    AndreyD Читатель

    Сообщения:
    22
    Симпатии:
    6
    Спасибо за ответы, буду постепенно разбираться.

    У меня задумка сделать Wifi розетку. У вас на форуме есть более подходящая тема для wifi розетки? Беглым просмотром тем я не нашел.
     
  8. Victor

    Victor Administrator Команда форума

    Сообщения:
    2.211
    Симпатии:
    386
    Вполне подойдет эта статья http://esp8266.ru/esp8266-blynk/
     
  9. AndreyD

    AndreyD Читатель

    Сообщения:
    22
    Симпатии:
    6
    Это более менее готовое решение, а я хочу сделать с нуля. Я уже собрал рабочий прототип на вот такой железке с питанием через два USB павербанка (второй на питание реле), теперь пробую на ESP-01. Все надо оптимизировать, минимизировать и впихнуть в какой-нибудь тройник или удлинитель.
     
  10. leehoi

    leehoi Новичок

    Сообщения:
    1
    Симпатии:
    0
    Схема собрана по статье http://esp8266.ru/esp8266-podkluchenie-obnovlenie-proshivki/#esp8266-test
    Толи прошивка AT20SDK93-2014-12-02 криво встает, толи ESP подбитая.
    Процесс доходит до 100%, но при попытки поиграть дальше в ESPlorer после 1 минуты работы светодиод красный горит тусклее и выдает следующее в логе :

    Fatal exception (0):
    epc1=0x4021b8a0, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000000, depc=0x00000000

    Пробовал перепрошивать на AT21SDK95-2015-01-24 не помогло, usb-ttl вообще перестает определяться как устройство в винде после выдергивания GPIO с GND.

    Как решить проблему?
     
  11. Victor

    Victor Administrator Команда форума

    Сообщения:
    2.211
    Симпатии:
    386
    более свежую прошивку взять
     
  12. oee

    oee Новичок

    Сообщения:
    3
    Симпатии:
    0
    [​IMG]

    при попытке подключения имею это, виртуальные порты менять пытался, безрезультатно
     
  13. VazapdrcMEN

    VazapdrcMEN Новичок

    Сообщения:
    1
    Симпатии:
    0
    Дд! при подключение к терминалу (CH_PD на VCC) и подаче любой ATкоманды выдает error.
    при попытке подключиться что бы прошить (CH_PD отключен GPIO0 на GND) через XTCOM_UTIL счетчик бежит после показывает ошибку при этом через телефон точку доступа я вижу и могу к ней подключиться. подскажите что я делаю не так?
    p/s/ покупал 2 модуля оба себя ведут одинаково EPS8266 01
     

Поделиться этой страницей